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A Introduction
In 2005, a collaboration started between the French National Institute for Agricultural Research
(INRA) and the farmer organization Réseau Semences Paysannes (RSP). The aim was: (1) to study
on-farm management of crop diversity; (2) to develop population-varieties adapted to organic and
low inputs agriculture in the context of a participatory plant breeding program involving farmers,
NGOs' facilitators and researchers.

In this project, researchers needed to map the history of the population-varieties using the network
formalism. In addition to the diffusion among farms, they wanted to document the other steps of life
cycle of the seed lot like the reproduction, the selection, and the cross steps. Data characterizing the
different seed lots were produced at each step like phenotyping and cultural practices data. All this
information needed to be centralized and stored.

Thus, we developed SHiNeMaS (Seeds History and Network Management System) a database with
its web interface, dedicated to the management of the history of seed lots and the associated data.

B Administration

B.1 Users management

B.1.a Create/Modify/Delete a user

To create users, go to the menu Admin data > Actors & Users > Users. This screen list all existing
users (Figure 1).

To create a new user click on ‘Add User’, a first form (Figure 2) ask to fill the login and password

of the new user. Click on ‘Save’ and finish to create the user filling useful information (First name,
last name, email) with the second form. If a user is destined to be an administrator of the database,
check the boxes  ‘staff status’ and ‘superuser status’.

Figure 1: User list



To edit a user, from the all users screen, click on the login. All information of a user can be updated
with the form. Click on ‘Save’ to validate the changes. To reset the password of a user follow the
link ‘this form’ in the ‘Password’ field set. To delete a user click on the ‘Delete’ button in the left
down corner of the form and then confirm in the next screen that you really want to delete this user.

B.1.b Users status

A user can have two status in SHiNeMaS : Administrator or read only. When creating/editing an
admin user, it is import to check the two boxes ‘staff status’ and ‘superuser status’ (Figure 1) that
the  user  has  a  full  access  to  administrator  features.  The  ‘superuser’  field  enables
create/modify/delete  features   on any data  in the database.  The ‘staff’ field gives access to  the
‘admin’ screens of the SHiNeMaS web interface (link at the right top corner). The two boxes must
be unchecked to create a read only user.

B.2 Projects and actors management

B.2.a Projects management

To manage projects go to the menu Admin data > Actors & Users > Projects. This screen displays a
list of all projects in the database.

To create a new project, click on ‘Add project’, the form must be filled with a name and the starting
date of this project. Click on the ‘Save’ button to validate it’s creation.

To edit a project, from the all project list screen, click on the name of a project. All information of a
project can be edited with the next form. Click on  ‘Save’ to validate modification.

To delete a project click on the ‘Delete’ button in the down left corner of the form and then confirm
deletion in the next screen.

Figure 2: New user creation form



B.2.b Network actors (Person) management

The ‘person’ or actors of the network are physical people who produce data to store in the database
without having necessarily a user access. To manage ‘people’ of SHiNeMaS go to the menu Admin
data > Actors & Users > Persons. This screen displays all people already existing.

To create a new person click on ‘Add person’, the form (Figure 3) must be filled with a first name, a
last name and a short name which will be used in many other screen of the app. By clicking on
‘Show’ a second part of the form is displayed in which contact information can be filled. Click on
‘Save’ to validate its creation.

To edit a person, from the people list screen, click on the short name. All information of a person
can be edited from the form. Click on ‘Save’ to validate the modification.

To delete a person, click on the ‘Delete’ button in the down left corner and the confirm the deletion
in the next screen.

B.2.c Location/farm (Location) management 

To manage locations in the app go in the menu Admin data > Actors & Users > Locations. This
screen shows all the existing locations.

To create a new location click on ‘Add location’. The form (Figure 4) must be filled with a name
and other optional information as well as a short name (mandatory) for this location. This short
name is import as it is used as described in « Rules about nomenclature of seeds lots» chapter. Click
on ‘Save’ to validate its creation.

Figure 3: New person form



To edit a location, from the all locations screen, click on a location name. All information except the
short name can be edited with the form. Click on ‘Save’ to validate the modification.

To delete a location click on the « Delete » button in the down left corner of the form and then
confirm the deletion in the next screen.

B.3 Biological entities management

B.3.a Species management

To manage species in SHiNeMaS go to the menu Admin data > Biological Entities > Species. This
screen displays all the existing species in the database.

To create a new species click on ‘Add species’. The form must be filled with a name (‘species’
field) as well as the Latin name and a description (optional) for this species. Click on ‘Save button
to validate its creation.

To edit a species, from the all species screen, click on its name. All information of a species can be
edited with the form. Click on the ‘Save’ button to validate the modification.

To delete a species, click on the ‘Delete’ button at the down left corner and then confirm deletion in
the next screen.

B.3.b Germplasm type management

To manage germplasm type in SHiNeMaS go to the menu Admin data > Biological  Entities >

Figure 4: New location creation form



Germplasm type. This screen displays all the existing germplasm type in the database.

To create a new germplasm type click on ‘Add germplasm_type’. The form must be filled with a
name for  this  type  as  well  as a  description for this  germplasm type.  Click on ‘Save button to
validate its creation.

To edit a germplasm type, from the all germplasm type screen, click on its name. All information of
a  germplasm  type  can  be  edited  with  the  form.  Click  on  the  ‘Save’ button  to  validate  the
modification.

To delete a germplasm type, click on the ‘Delete’ button at the down left corner and then confirm
deletion in the next screen.

B.3.c Germplasm management

To  manage  germplasm  in  SHiNeMaS  go  to  the  menu  Admin  data  >  Biological  Entities  >
Germplasm. This screen displays all the existing germplasm in the database.

To create a new germplasm click on ‘Add germplasm’. The form must be filled with a name for this
germplasm. It’s also possible to fill a germplasm type, a species (recommended) as well as the
person who create this germplasm. Click on ‘Save button to validate its creation.

To edit  a  germplasm,  from the  all  germplasm screen,  click  on  its  name.  All  information  of  a
germplasm can be edited with the form except its name as it would impact all seeds lot names as
described in  « Rules  about  nomenclature  of  seeds  lots» chapter.  Click  on the  ‘Save’ button  to
validate the modification.

To delete  a  germplasm, click  on the ‘Delete’ button at  the down left  corner  and then  confirm
deletion in the next screen.

B.3.d Seeds lot management

To manage seeds lot go to the menu Admin data > Biological Entities > Seed lot.

It is not possible to create new seeds lot with admin web interfaces. New seeds lot are created
through network events (see Seeds lot network management).

To edit a seeds lot, from the all seeds lot screen, click on its name. Only few information can be
edited with this form. The name, the germplasm, creation date can’t be edited as it would have an
impact on all the descendants of this seed lot. Generation information can be edited but information
of the descendants and ascendants is not yet recalculated. It’s up to the user to be careful with this
information. Click on the ‘Save’ button to validate the modification.

To delete a seeds lot, click on the ‘Delete’ button at the down left corner and then confirm deletion
in the next screen.

B.4 Seeds lot network management

B.4.a Reproduction method management

To manage reproduction methods in SHiNeMaS go to the menu Admin data > Data Descriptors >
Repro. method. This screen displays all the existing reproduction methods in the database.

To create a new reproduction method click on ‘Add reproduction_method’. The form must be filled
with a name for this method as well as a description (optional) for this method. Click on ‘Save
button to validate its creation.

To edit a reproduction method, from the all reproduction methods screen, click on its name. All
information of a reproduction method can be edited with the form. Click on the ‘Save’ button to
validate the modification.



To delete a reproduction method, click on the ‘Delete’ button at  the down left corner and then
confirm deletion in the next screen.

B.4.b Data methods management

To manage data methods in SHiNeMaS go to the menu  Admin data > Data Descriptors > Data
method. This screen displays all the existing data methods in the database.

To create a new data method click on ‘Add method’. The form must be filled with a name for this
method as well as a description, a unit and some other information (optional) for this method. Click
on ‘Save button to validate its creation.

To edit a data method, from the all data methods screen, click on its name. All information of a data
method can be edited with the form. Click on the ‘Save’ button to validate the modification.

To delete a data method, click on the ‘Delete’ button at the down left corner and then confirm
deletion in the next screen.

B.4.c File preparation

B.4.c.i Submitted file format

The submission files in SHiNeMaS are « tabulated » files and must fit with the following rules :

• Text file

• Column separator : tabulation

• Text delimiter : "

For example, a file open with a simple text editor, that will be submitted into SHiNeMaS must look
like this :

"project" "location" "id_seed_lot" "etiquette" "event_year" "split" "quantity"

"PPB" "FLM" "Rouge-du-Roc_JFB_2004_0001" 2004 1 250

"PPB" "FLM" "Clomone_JFB_2004_0001" 2004 1 122

Each file type is described by mandatory fields (headers). It is possible to add additional columns
regarding  the  method  file  (chapter  B.4.c.ii).  With  this  feature  a  user  can  customize  variables
definition.

B.4.c.ii Method file

Description

The method file contains the description of measures and the methods used to make these measures.
Four fields described this file :

• variable : the name of the measured variable

• type : the type of the variable (variable types are described in the next chapter)

• method_name : the name of the method used to measure this variable.

• correlation_group : correlation groups used for this variable. Correlation groups usage is
described in after the « variable type » chapter.

Variable type

Each data can have a different scope regarding the context. The scope affect how data are linked to
the relations in a particular event. The table 1 described the variable types regarding their scope.



Type Scope 
Type 1 Whatever the event type, the data is linked to all the relations. 
Type 2 In a breeding-cross the data is linked to the male relation
Type 3 In a breeding-cross the data is linked to the female relation
Type 4 In a reproduction, the data is linked only to the selection
Type 5 In a mixture, the data is linked to only one relation of the mixture
Type 6 In a reproduction, the data is linked to any relation that is not a 

selection
Type 7 The data is linked to the parent seeds lot
Type 8 The data is linked to the child seeds lot
Type 9 In a breeding-cross, the data is linked to the male seeds lot
Type 10 In a breeding-cross, they data is linked to the female seeds lot
Type 11 The data is  an individual data

Table 1: Definition of the variable type and their scope

Correlation groups

Correlation groups are used for individual data. Let’s consider a data series (at a same date for
example) on numerated individuals. For the next series (at another date) the user collect data on the
same number of individuals. But two scenarios can occur :

• The numerated individuals are not the same (You lost the numeration between the two series
of data). In that case the data of the first series and the second series can’t be correlated as
it’s haven’t be done on the same individuals. Example :  Figure 5, on a single line, data in
green, blue and orange aren’t correlated and belongs to 3 different groups B, C, and D

• The  numerated  individuals  are  the  same.  In  that  case  all  data  can  belong  to  the  same
correlation group. Example : Figure 5, the lines in yellow. The data belongs to the group A.

In the method file you should report in the correlation_group column all the correlation groups in
which a variable is implied (Figure 6). For example, the variable ‘plant_height’ is implied in the
correlation groups A (yellow) and B (green).

Figure 5: Individual data file – correlation groups



Particular case

It is possible to measure a same variable with two different method. To do the variable must be
tagged with a prefix in the data file and in the method file. The following syntax is used (see Figure
7)  :

prefix%variable_name

B.4.c.iiiRules about nomenclature of seeds lots

Case of already existing seed lots in the database

A nomenclature has been defined in SHiNeMaS in order to ensure the uniqueness of the data base
seeds lots names. It bases on 3 indications : the name of the variety (VARIETE), the seed lot’s
creation year (ANNEE) and the location of this seed lot (LOCATION). We can imagine that one
single variety has given several seed lots during one year on a single location. Therefore, a fourth
indication is used : a four digits code (NUM) ensuring the uniqueness of a seeds lot.

Those indications are separated by an underscore (‘_’). The use of this character is then forbidden to
define a variety’s name or the short name of a person.

A seeds lots’ name is written as follows :

VARIETE_ANNEE_PERSON_NUM

Figure 6: Fichier méthodes - groupes de corrélation

Figure 7: prefix usage to define a variable used with two methods



Case of non already existing seeds lots in the database

This case happens when a seed lot enters the seeds history network although it has never appeared
in the network before. In that case, the user has to indicate the following indications in the box
corresponding to the seeds lot ID :

VARIETE_ANNEE_PERSON

The app will calculate automatically the four digits extension necessary to (1) ensure the uniqueness
of the seeds  lot’s  name and (2)  respect  the nomenclature defined in  SHiNeMaS. If  the variety
VARIETE doesn’t exist in the database, it would be created automatically.

It is important to indicate that it is possible to use the same structure VARIETE_ANNEE_PERSON
several times in a single file. The app will consider that it refers to the same seeds lots used several
times.

Selections’ cases

When a selection is done  (chapter B.4.c.viii) the seeds lot’s name follows a specific nomenclature
including the selection’s name (SEL) :

VARIETE#SEL_ANNEE_PERSON_NUM

The  ‘#’ character  (diez)  is  used  to  combine  the  variety’s  name  to  the  selection’s  name.  This
character cannot be used in the variety’s name. The expression VARIETE#SEL will be transferred
to all the descending seeds lots when it is a reproduction or a spreading. If a new selection (NSEL)
is done on a descending seeds lots, the expression SEL is then replaced by NSEL as follows :

VARIETE#NSEL_ANNEE_PERSON_NUM

As a mixture or a cross-breeding creates a new variety, the selection name’s indication disappears
and the seeds lot’s name a classic nomenclature described in the first paragraph.

B.4.c.ivCross-breeding file

Objective

This file allows to create cross-breeding events between different varieties, as shown on Figure 8. A
cross-breeding creates a new variety.

File structure

The breeding file describes the information necessary to create a cross-breeding event in the 
database. The fields needed to create a breeding are the following :

• project : Project in which the event has occurred

Figure 8: Cross-breeding picture



• sown_year : Parents seeds lots’ sown year.

• harvested_year : Harvest year of the seed lot descended from the cross-breeding

• quantity_harvested : Quantity harvested after the cross-breeding. It is the initial quantity of
the harvested seeds lot.

• cross_year : Year of the cross-breeding

• cross_germplasm : Name of the new created variety

• number_crosses : Number of cross-breeding done 

• kernel_number_F1 : Number of seeds obtained from the cross-breeding and used for the 
F1

• male_seed_lot : ID of the seeds lot used as a male

• male_etiquette: Label used for the male seed lot

• male_split: Indicates if the entire seed lot was used at cross-breeding: 0 for all and 1 
otherwise

• male_quantity: Quantity of seeds from the seed lot used 

• male_block: Block in which the seed lot has been sown

• male_X: X coordinate of the male seed lot

• male_Y: Y coordinate of the male seed lot

• female_seed_lot: Identifier of the seed lot used as female

• female_etiquette: Label used for the female seed lot

• female_split: Indicates if the entire female seed lot was used for the cross-breeding: 0 for all
and 1 otherwise

• female_quantity: Quantity of the female seed lot used

• female_block: Block in which the female seed lot has been sown

• female_X: X coordinate of the female seed lot

• female_Y: Y coordinate of the female seed lot

Prepare a file

To prepare a cross-breeding file, go to the Prepare & Upload File> Prepare Files> Cross menu. This
interface provides a “download template file” link to download a file filled with mandatory headers
for cross-breeding.

A simplified search interface (Figure 9) suggests to search for seeds already filled in the database
according to 3 criteria: year of creation, projects in which they are used, place on which they are
stored.



A list is displayed with two icons  that allow by a single click to add the seed lot to a list of
lots that will be used as male or female (Figure 10). This list is visible by clicking on the icon  on
the right of the results list. The lots are grouped by two (male / female). This action brings up a
window that allows you to delete pairs of seed lots from the list or to complete the file preparation

information.

Clicking on the 'Export File' button will download the pre-filled cross-breeding file. A user can also
modify the search filters and restart it to complete his list of seed lots.

Figure 10: Cross file preparation interface

Figure 9: Simplified search form



B.4.c.v Diffusion file

Objective

This file is used to create diffusion events. A diffusion makes possible to send a seeds lot, entirely or
partly, from a place A to a place B, as represented on Figure 11.

File structure

The diffusion file describes the information needed to create a diffusion event in the database. The
fields required to create a diffusion are:

• project : Project in which the diffusion takes place

• location : Place where the seed lot is diffused

• id_seed_lot : Identifier of the "parent" sent seed lot

• etiquette : Label used for the parent seed lot

• event_year : Year of the diffusion

• split : Indicates if the entire "parent" seed lot has been diffused: 0 for all and 1 otherwise

• quantity : Quantity of seed lot released ("child" seed lot)

Prepare a file

To prepare a diffusion file, go to the menu Prepare & Upload File> Prepare Files> Diffusion. This
interface provides a “download template file” link to download a file filled with mandatory headers
for a diffusion event.

A simplified search interface (Figure 9) suggests to search for seeds already filled in the database
according to 3 criteria: year of creation, projects in which they are used, place on which they are
stored.

A list is displayed (Figure 12), you should select in a drop-down list the place of destination, then
click  on  the icon to add the seeds lots that will be used in a distribution relationship. The list
is visible by clicking on the  icon on the right of the results list. This action brings up a window
that allows you either to erase seed lots from the list or to complete the file preparation information.

Figure 11: Diffusion picture



Clicking on the 'Export File'  button will  download the pre-filled diffusion file.  A user can also
modify the search filters and restart it to complete his list of seed lots.

B.4.c.vi Mixture file

Objective

This file is used to create mixture events as shown in Figure 13. A mixture consists in using at least
two seeds lots and grouping them into a single seeds lot. There is no limit on the number of seed
lots that can be mixed. However, all seed lots must come from the same place. A mixture leads to
the creation of a new variety.

File structure

The mixture file describes the information needed to create a mixture event in the database. The
mixture file has the particularity of describing a mixture event on several lines of the file. Each line
describes a lot of seeds used in the mixture. The germplasm field, repeated on several lines, makes
possible to group the seeds lots that are used in the same mixture. The fields needed to create a
mixture are:

• project : Project in which the mixture has been done

Figure 12: Diffusion file preparation interface



• id_seed_lot : Identifier of the « parent » seeds lot mixed

• etiquette : Label used for the « parent » seeds lot

• split :  Indicates  if  the  entire  seeds  lot  has  been  used  for  the  mixture :  0  for  all  and  1
otherwise

• quantity : Quantity of the « parent » seeds lot mixed

• germplasm : Name of the created new variety

• event_year : Year of the mixture

Prepare a file

To prepare a mixture file, go to the Prepare & Upload File> Prepare Files> Mixture menu. This
interface provides a “download template file” link to download a file filled with mandatory headers
for a mixture.

A simplified search interface (Figure 9) suggests to search for seeds already filled in the database
according to 3 criteria: year of creation, projects in which they are used, place on which they are
stored.

A list is displayed (Figure 14), you should indicate in a field text the name of the mixture and then
click on the  icon to add the seeds lots that will be used in a mixing relationship. The list is
visible by clicking on the icon on the right of the results list. This action brings up a window
that allows you to either clear relationships from a mixture of seed lots or to complete the file
preparation information.

Figure 13: Mixture picture



Click on the 'Export File' button to download the pre-filled mixture file. A user can also modify the
search filters and restart it to complete his list of seed lots.

B.4.c.vii Reproduction file

Objective

This file makes it possible to create reproduction events as described on Figure 15. A reproduction
takes place on a given place, at a given position, defined by its block and its X and Y coordinates.

A reproduction consists in sowing a seed lot at one or more locations and then harvesting the seed
lot(s).

Figure 14: Mixture file preparation interface

Figure 15: Reproduction picture



File structure

This file makes it possible to create reproduction events as described on Figure 4. A reproduction
takes place on a given place, at a given position, defined by its block and its X and Y coordinates:

• project : Project in which the reproduction takes place

• sown_year : Sowing year of the parent seed lot

• harvested_year : Harvest year of seed lot "child"

• id_seed_lot_sown : ID of the « parent » sown seed lot

• intra_selection_name : Name of the selection

• etiquette : Label used for the « parent » seed lot

• split : Indicates if the entire « parent » seed lot has been sown : 0 for all, 1 otherwise

• quantity_sown : Quantity of the « parent » seed lot used

• quantity_harvested : quantity harvested for the « child » seed lot

• block : location block of the reproduction

• X : coordinate X

• Y : coordinate Y

Prepare files

Two scenarios can occur to create a reproduction file. Either the file is submitted a first time (at
sowing, for example). In this case the user will select a list of lots of seeds to be sown. In the second
case  the  user  will  submit  a  file  containing  measurements  on  already existing  reproductions  (a
sowing file already submitted).  In this  case the user will  select reproductions from a list.  Both
interfaces provide a “download template file” link to download a file filled with mandatory headers
for reproduction.

To prepare a sowing file

To prepare a reproduction file go to the menu Prepare & Upload File> Prepare Files> Reproduction.

A simplified search interface (Figure 9) suggests to search for seeds already filled in the database
according to 3 criteria: year of creation, projects in which they are used, place on which they are
stored.

A list is displayed (Figure 16) that allows you to click on the  icon to add the seed lots that will
be used in a reproduction relationship. This list is visible by clicking on the  icon on the right of
the results list. This action brings up a window that allows you either to erase reproductions or to
complete file preparation information.



Clicking on the 'Export File' button will download the pre-filled reproduction file. A user can also
modify the search filters and restart it to complete his list of seed lots.

Prepare an existing reproductions file

To prepare an existing reproductions file, go to the menu Prepare & Upload File> Prepare Files>
Existing Reproduction.

A simplified search interface (Figure 9) suggests to search reproductions already existing in the
database according to 3 criteria:  year of creation of the seed lot  seeded, projects  related to the
reproduction, place on which the reproduction takes place.

A list is displayed (Figure 17) which allows by a simple click on the icon  to  add  the
reproductions to be exported in the file. The reproductions are here defined by the name of the seed
lot sown and the location of the sowing. This list is visible by clicking on the icon  on  the
right  of  the  results  list.  This  action  brings  up  a  window  that  allows  you  either  to  delete
reproductions or to complete the file preparation information.

Figure 16: Reproduction file preparation interface



A click on the 'Export File' button will download the pre-filled reproduction file. A user can also
modify the search filters and restart it to complete his list of reproductions.

B.4.c.viii  Selection file

Objective

This file is  used to create  selection events  as shown in  Figure 18.  A selection event  is  always

associated with a reproduction. A selection can be made by an actor of the network.

Figure 17: Existing reproduction file preparation interface

Figure 18: Selection picture



File structure

The selection file describes the information needed to create a selection event in the database. The
fields required to create a selection are :

• project : Project in which the selection takes place

• sown_year : Sowing year of the « parent » seed lot

• harvested_year : Harvest year of seed lot « child »

• id_seed_lot_sown : Identifier of « parent » seed lots 

• etiquette : Label used for the « parent » seed lot

• block : block where the reproduction take place

• X : X coordinate

• Y : Y coordinate

• selection_person : Short name informing the person who made the selection

• selection_quantity_ini : Quantity selected

• selection_name : Name given to this selection

Prepare a file

To prepare a selection file go to the menu Prepare & Upload File> Prepare Files> Intra seed lot
selection. This interface provides a “download template file” link to download a file filled with
mandatory headers for a selection event.

A simplified search interface (Figure 9) proposes to search reproductions already existing in the
database  according  to  3  criteria:  year  of  creation  of  the  seed  lot  sown,  projects  related  to  the
reproduction, place on which the reproduction takes place.
A list is displayed (Figure 19) which allows you to click on the icon      to  add  the
reproductions to be exported to the file. The reproductions are here defined by the name of the seed
lot sown and the location of the sowing.  This list is visible by clicking on the icon  on  the
right of the results list. This action brings up a window that allows you to either erase reproductions
or complete file preparation information.



Clicking on the 'Export File'  button will  download the pre-filled selection file.  A user can also
modify the search filters and restart it to complete his list of reproductions.

B.4.c.ixIndividual data file

Objective

This file is used to enter individual data concerning reproductions or selections. Individual data is
associated with numbered individuals.

File structure

The individual data file describes the information needed to insert individual data into the database.
The fields required to insert this data are as follows:

• project : Project in which the selection takes place

• sown_year : Sowing year of the « parent » seed lot

• harvested_year : Harvest year of seed lot « child »

• id_seed_lot_sown : Identifier of « parent » seed lots 

• intra_selection_name : Name of selection if applicable

• sown_etiquette :Label used for the « parent » seed lot 

• id_seed_lot_harvested :  Identifier of the « child » seed lot harvested

• harvested_etiquette : Label used for the «child» seed lot 

• block : block where the reproduction take place

• X : X coordinate

• Y : Y coordinate

• individuals : Number of the individual

Figure 19: selection file preparation interface



Prepare a file

To prepare  a  file  of  individual  data,  go  to  the  menu  Prepare  &  Upload  File>  Prepare  Files>
Individual data. This interface provide a “download template file” link to download a file filled with
mandatory headers for individual data.

A simplified search interface (Figure 9) proposes to search reproductions already existing in the
database  according  to  3  criteria:  year  of  creation  of  the  seed  lot  sown,  projects  related  to  the
reproduction, place on which the reproduction takes place.

A list is displayed (Figure 20) which allows you to click on the  icon to add the reproductions to
be exported to the file. 
The reproductions are here defined by the name of the seed lot sown and the location of the sowing.
This list is visible by clicking on the  icon on the right of the results list. This action brings up a
window that allows you to either erase reproductions or complete file preparation information.

Click on the 'Export File' button to download the pre-filled individual data file. A user can also
modify the search filters and restart it to complete his list of reproductions.

B.4.c.x Prohibited characters in the different SHiNeMaS fields

Information List of prohibited characters
Germplasm names #, _, space
Short name of person #, _, space
Name of variables %

Table 2: Summary of prohibited characters in the different SHiNeMaS fields

Figure 20: individual data file preparation interface



B.4.d Submission of the file

B.4.d.i File submission interface

In Import / Export> Upload, choose a data file in the "File" field, a method file in the "Method"
field.  Select  the correct  file  type  from:  Cross,  Diffusion,  Mixture,  Multiplication,  Intra  varietal
selection or Individual data. Click on "Submit".

B.4.d.ii Special treatments when submitting a file

Special treatments common to all files

• When the  project field  indicates  a  project  that  does  not  exist  this  one  is  automatically
created by the application

• Seed lots that do not exist in the database are treated as described in chapter 'Case of non
already existing seeds lots in the database'

Case of crosses

• In the case of a  number_crosses equal to 0 the application generates a virtual seed lot
named  according  to  the  nomenclature  NOTCROSSED_NUM,  NUM  ensuring  its
uniqueness.

• In the case of a kernel_number_F1 equal to 0 the application generates a virtual seed lot
named  according  to  the  nomenclature  NOTCROSSED_NUM,  NUM  ensuring  its
uniqueness.

Case of reproductions

• When reproduction is in progress at a given place (even location, X, Y) you can not sow a
seed lot of the same species.

• However, you can add data to a current reproduction. The reproduction will be identified by
the same seed lot sown at the same place.

Figure 21: File submission interface



Case of selections

• A selection is always associated with a reproduction (identified by the seed lot sown, and its
place).  However, if a selection event is filled in a file but no reproduction matches, the
application will create a new reproduction. 

• A selection name can only be used once for a germplasm

Case of individual data

• Reproductions declared in the individual data file must exist

B.4.e Submission reports

B.4.e.i Successful submission

A report  is  produced  after  each  submission  (Figure  22).  This  submission  report  summarizes
information that was included into the database. This information is of different types and indicates:

• New created variables

• New created varieties

• New created seed lots

• New created relation between seed lots

Figure 22: Report of a successful submission



• On going replicates

• Seed lots without initial quantity

• Relations which quantities are not indicated

• Reproductions which coordinates are not indicated

It is also possible to perform some actions directly from the submission report. These actions are
detailed in the next section (Post-submission processing)

B.4.e.ii Interpretation of the error message

In some cases, file submission can produce errors (Figure 23) that stop the submission process
before the end. In this case, all on going operations are canceled and an error report is produced.

These errors can be of different types :

• a variable was found in the method file or in the data file and not within the other.

• one line of the file was not associated to a project

• a method did not exists in the database

• a variety already existed in the database (in the case of crossing or mixture)

• The variety name contained a forbidden character

• One actor of the network no longer exist

• The seed lot name was not filled

• The seed lot name contained a forbidden character '#'

• The seed lot no longer exist in the database

Figure 23: Errors report



• No-valid value for a ‘split’ field (i.e. value different of 0 or 1)

• Seed lot nomenclature was not respected

• Some mandatory fields were empty

• Some correlation groups were inconsistent

• Some dates were inconsistent (for instance : sowing date after harvesting date)

• Some errors were detected for the locations of the reproductions

B.4.f Post-submission processing

B.4.f.i To associate a variety type

It is possible to associate a variety type for a variety newly created directly from the submission
report.  Variety  types  need  to  be  created  previously  to  the  association  (Germplasm  type
management). In the table Figure 24 the column 'Choose a germplasm type' allows to select which
type of variety to be associated to the variety name cited in the column  'Germplasm'. Click on the
'Submit' button only after associating all the varieties types to the varieties.

It is always possible to modify the type of variety associated to a variety after this step. How to
modify the type of the variety is explained in section Germplasm type management.

B.4.f.ii To associate a reproduction type

It  is  possible  to  associate  a  reproduction  type  to  an  on  going  reproduction  directly  from the
submission report.  To be able to make such associations, reproduction types need to be created
before the production of the submission report (Reproduction method management). In the example
Figure 25 the line 'Choose the reproduction type' allows to select which type of reproduction is

Figure 24: Template allowing to associate a type of variety to a variety



associated to the reproduction describes on the above line. Click on the 'Submit' button only after
finished all the associations.

It is always possible to modify the type of reproduction associated to the reproduction.

B.4.f.iii To merge seed lots coming from different replicates after a 
submission

It is also possible to merge on going seed lots coming from different replicates from the submission
report. Each series of seed lots distributed in different replicates is separated by '***' (Figure 26).
Seed lots that needs to be merged can be selected by checking proper boxes. After selecting the seed
lots, clicking on the 'Merge' button. It is necessary to repeat this operation for each series of seed
lots distributed in different replicates.

Merging seed lots coming from different replicates leads to create a new mixture event without
creating a new variety (mixture excepted). Be careful, this operation is irreversible.

Figure 25: Form to link a reproduction method to a running reproduction from the submission 
report



It is always possible to perform this operation latter on if the user leaves the report submission
before merging all the needed seed lots coming from different replicates (Event creation through
administration interface).

B.4.g Edit raw data

From the menu Admin data > Seed lot relation >  Any relation type >  Edit raw data, a user can

access to a simple autocompletion list where he can choose the relation containing the data to edit.
As soon as the event card appears the user, if he is an administrator of the database, can click on a

Figure 26: Merge repetitions after a submission

Figure 27: Form enabling data edition from a card



data and display a form in which the data can be edited (Figure 27). When a data is edited, the user
can add a comment to explain why this edition, or keep the track of the previous value. Note that
the date of the last update and the username is also track and displayed in the data table in the card
when moving the mouse over the value.

B.4.h To merge seed lots coming from different replicates

Seed  lots  coming  from  different  replicates  can  be  merged  by  the  admin  user  later  after  the
submission step of reproduction file. To process to such change, go to the menu :Admin data >
Tools > Merge Reps. A screen (Figure 28) shows all the seed lots coming from different replicates
that can be merged. It is possible to select/unselect seed lots to merge for each line. Select the
corresponding project that need to be link to this event and click on the ‘Merge’ button. A message
appears with the name of the new created seed lot when operation happens successfully.

B.4.i Event creation through administration interface

Administration interfaces help the user to create on-time event, independent to the file submission.
They allow to gather events older than a series of event already documented in the database. 

Figure 28: Merge repetition screen

Figure 29: New diffusion creation form



B.4.i.i Diffusion

To  go  to  the  menu:  Admin  data  >  Network  >  Diffusion  >  New,  to  create  a  diffusion  event.
Administrator interface is divided into three blocks of information (Figure 29). In the block ‘Seed
lot diffused’, the user has to fill the diffused seed lot (to choose within a list of existing seed lots) or
to provide information to create a new one. In the block ‘Diffusion information’, the user has to fill
the targeted seed lot involved in the diffusion relation by selecting within the list of the existing
seed lot or by creating a new one by filling the fields ‘receiver’ and ‘event_year’. The user has to
fill the other fields of the block. The different rules to create a diffusion event by loading a file
(Special treatments when submitting a file) also apply to this interface. Note that when the user

selects an existing seed lot within the block ‘Diffusion information’, this one cannot be created by
any  other  relation.  Otherwise,  an  error  message  will  appear.  Finally,  in  the  block  ‘Additional
information’ the user can add data linked to this diffusion event. By clicking on the  button make
additional lines appear. Then, to click on the ‘Create’ button to valid the event creation.

Figure 29: New diffusion creation form

Figure 30: Reproduction creation form



B.4.i.ii Reproduction

To go to the menu: Admin data > Network > Reproduction > New, to create a reproduction event.
The administration interface (Figure 30) is divided into three blocks of information. In the block
‘Sown seed lot information’, the user has to fill the seed lot that was sown by choosing within a list
of  existing  seed  lots  or  by filling  the  required  information  to  create  a  new one.  In  the  block
‘Reproduction information’ the user has to fill the harvested seed lot by selecting the seed lot in the
list  coming  from  the  reproduction  relation  or  by  creating  a  new  one  by  filling  the  field
‘harvested_year’. The user has to fill the other fields of the block. The different rules to create a
reproduction event by loading a file (Special treatments when submitting a file) also apply to this
interface.  Note  that  when  the  user  select  an  existing  seed  lot  in  the  block  ‘Reproduction
information’, this one cannot be created by any other relation. Otherwise, an error message will

appears.  Finally,  in  the  block  ‘Additional  information’ the  user  can  add  data  linked  to  this
reproduction event. By clicking on the (+) button make additional lines appear. Then, to click on the
‘Create’ button to valid the event creation.

Figure 30: Reproduction creation form



B.4.i.iii  Selection

To go to the menu : Admin data > Network > Selection > New, to create a selection event . The
administration  interface  (Figure  31)  is  divided  into  two  blocks  of  information.  In  the  block
‘Selection information’, the user has to fill an existing reproduction event by choosing it within a
list.  Then, to fill  the other field of the block. The different rules to create a selection event by
loading a file (Special treatments when submitting a file) also apply to this interface. Finally, in the
block ‘Additional information’ the user can add data linked to this selection event. By clicking on
the (+) button make additional lines appear. Then, to click on the ‘Create’ button to valid the event
creation. 

Figure 31: Selection creation form



B.4.i.iv  Cross

To  go  to  the  menu :  Admin  data  >  Network  >  Cross  >  New,  to  create  a  cross  event.  The
administration interface (Figure 32) is divided into four blocks of information. In the block ‘Male
seed lot information’, the user has to fill the male seed lot by choosing within a list of existing seed
lots, or by providing information to create a new one by filling the fields ‘location’, ‘year’, and
‘germplasm’. Then, one has to fill information relative to the sowing of the male seed lot. In the
block ‘Female seed lot information’, the user has to fill the female seed lot by choosing within a list
of existing seed lots, or by providing information to create a new one by filling the fields ‘location’,
‘year’, and ‘germplasm’. Then, one has to fill sowing information of the female seed lot. In the
block ‘Cross information’, the user has to fill the targeted seed lot of the cross relation by selecting

it within a list, or by filling field ‘species’ and ‘germplasm’ to create a new one. Then, the user has
to fill the other fields of the block. The different rules to create a cross event by loading a file
(Special treatments when submitting a file) also apply to this interface.

Note that when the user select an existing seed lot in the block ‘Cross information’, this one cannot
be created by any other relation. Otherwise, an error message will appears. Finally, in the block
‘Additional information’ the user can add data linked to this cross event. By clicking on the button
make additional lines appear. Then, to click on the ‘Create’ button to valid the event creation.

Figure 32: New cross form



B.4.j Delete information

B.4.j.i Delete an event through the administration interface

To go to the menu : Admin data > Network > « Event type » > Delete, to remove an event. The user
can access to an administration interface which lists all the events of the event type selected by the
user. On the right, filters help the user to limit this list. This page allows to select different events
and to remove them through the ‘Delete selected « event »’ action. Nevertheless, this method is to
avoid because deletion would be partial. To remove an event properly, it is advised to click on its
name. The page of the event details appears and propose two kinds of deletion :

• The ‘Delete’ button helps the user to remove the considered event with all the associated
data/measurements at the condition that these data are not associated themselves to another
event. If the « child » seed lot is not used in any other relation, it is also removed. 

• The ‘Delete in cascade’ button helps the user to remove the considered event with all the
posterior  events  resulting  of  this  event.  On  the  same  way,  all  the  associated
data/measurements  will  be  removed  at  the  condition  that  these  data  are  not  associated
themselves to another event.

In the both cases, the user will be directed to a page that will ask him to confirm the deletion. To
confirm the choice, to click on the ‘Yes I’m sure’ button. Otherwise, to click on the ‘No, take me
back’ button.

B.4.j.ii Delete reproduction events from a file

From the menu Prepare & upload files > Delete from file > Reproduction, a user can delete a set of
events by submitting a file. The first step (Figure 33) aims to sumbit a reproduction file. This file
has the same format that the one described in the chapter   Prepare an existing reproductions file.
The deletion can be done in cascade or not as described in the chapter Delete an event through the
administration interface. The second step read the file and inform the user of the reproductions that
will be deleted. If the user accepts the reproductions are deleted and a report is displayed (step 3).
The user can also go back to the submission form.

Figure 33: The 3 steps to delete reproduction events with a file



B.4.j.iii Delete raw data from a query

From the menu Admin > Seed lot relation > Reproduction > Delete raw data a user can delete a set
of raw data without deleting related reproductions. Raw data can be selected with a form (Figure
34) filtering according to locations, germplasms, variables, a range of date (including also data
without date), and the sowing year. The second step list all the raw data found as result of the query.
The user can select/unselect each value before validation. As soon as the user has accepted his
selection a report  is  displayed with the number of raw data deleted for each reproduction.  Just
below this report the user can download two templates files filed with the relations and the variables
related to the raw data deleted.

C Consulting data

C.1 Global search toolbar

From any screen in SHiNeMaS a global search bar at  the top of the web interface (Figure 35)
provide a useful tool to search any kind of information (Germplasm, Seed lot or Relation) in the
database. The search is done by auto-completion, meaning that a user starts to write a text in the bar
and a restricted list is shown in the bar. As soon as an object is selected a click on the “Go” button
forward to the corresponding card (see below the description of the cards).

Figure 34: Steps to delete raw data of a reproduction event



C.2 Advanced query

C.2.a Filters

The  Advanced  query  interface  (Figure  36)  makes  possible  to  filter  results  according  to  some
criteria :

• 'Creation year' : creation year of the seed lot. It can be harvesting year, reception year (in the
case of a diffusion), mixture year etc.

• 'Projects' : projects in which the seed lot is used

• 'Person' : person owning this seed lot

• 'Relation  type' :  Filter  on  relation  type  which  creates  this  seed  lot  (Diffusion,  mixture,
reproduction etc.)

Figure 36: Advanced query form

Figure 35: Global search toolbar



• 'Germplasm' : Filter on germplasm

Each filter offers a box 'Not' which allows to define an exclusion criteria (« All except »...). Click
on the « Search » button to apply filters.

C.2.b Classic mode

The  « Classic »  query  mode  shows  the  list  of  seed  lot  from  applied  filters.  Some  additional
information are available :

• Seed lot name : the name of the seed lot

• Relation : The relation type that produce this seed lot

• Parent names : The names of parents seed lot

• Grandparents Relation : The relation type that produce parents seed lot

• Grandparents : The names of grandparents seed lot

• Selection name : The selection name when the seed lot is produced from a selection

• Selection person : Person who made the selection when a seed lot is produced from a 
selection

• Origin seed lot : Location where the seed lot comes from

• Diffusion date : Year of the last diffusion of the seed lot

Figure 37: « Classic » mode query result



C.2.c Generation mode

The « Generation » query mode (Figure 38) shows the list of seed lot according to selected filters. It

also shows information about generation number (total and on a same location)  :

• Seed lot name : Seed lot name

• First parents : Name of the parents used for the cross from origins (when there was one)

• Total number of generation : Total number of multiplication needful to obtain this seed lot

• Number of generation on the last farm : Number of multiplication that happened on this 
location to obtain this seed lot

• Confidence : Confidence accorded to the number of generation. For example a seed lot 
which integrate spontaneously the network will have a default confidence at false

• Confidence on last farm : Confidence accorded to the number of generation on a same 
location.

C.2.d Measures mode

The «Measures» query mode shows collected data on a given time interval (Figure 39). User fill

Figure 38: "Generation" mode query result



variables name in the form and the dates that define the time interval. The results are shown in 3
tables :

• Seed lot data : the table displays the seed lot name and data related to this seed lot.

• Individual data related to the relations : the table displays the name of the relation as well
as coordinates in the field, individual number and data related to this individual.

• Global data related to the relations : the table displays the name of the relation as well as
coordinates of the reproduction and data related to the plot.

C.3 Selection table

The selection table (Figure 40) displays a table with all the selection names used for a germplasm.
You can find it in the « Admin data > Tools > Selection table » menu. When many selection already

Figure 39: "Measure" mode query result

Figure 40: Table des sélections



occurred, a form (germplasm and selection name) is available to test if the name is already used.

C.4 Seed lot card

Advanced query displays a list of seed lot (Advanced query). By clicking on the name of a seed lot,
it is possible to view the seed lot card (Figure 41).

The card gives information ('seed lot information' frame) about the variety of the seed lot, its owner,
its creation date (harvesting, diffusion, mixture etc.) as well as the project in which the seed lot is
used.

History of the seed lot is also displayed, especially the event that created the seed lot and the events
in which it is used ('seed lot history' frame).

At last, the frame 'stock information', displays data about stock information if the seed lot.
Figure 41: Seeds lot card



C.5 Germplasm card

From a seed lot card (Seed lot card chapter) it  is possible to click on the name of a variety to
displays its card (Figure 42).

The 'Germplasm information' frame shows the name of the variety, the person who obtained this
variety when information is available, as well as the type of the variety.

The 'Germplasm history' frame displays how the variety has been created especially when it is a
cross or a mixture.

At last, the 'stock information' frame shows who owns seed lots of this variety. Contact information
can be shown when it is possible.

Figure 42: Germplasm card



C.6 Relation card

From a seed lot card (Seed lot card chapter) it is possible to click on the ‘relation’ icon to display
its card (Figure 43).

The ‘Relation information’ frame displays the type of the relation, as well as all information related
to this relation (date, coordinates when it is a cross or a reproduction, quantity used etc.)

The ‘Data’ frame displays all data collected in this relation.

C.7 Download data

From any card or from the advanced query result table it is possible to download the data table by
clicking on the  icon. 

D Lexique
• Repetition: plots of the try that contains the same seed lot.

• Reproduction : A reproduction is the cycle of the plant, a seed grow to give new seeds.

• Selection  :  inside  a  seed  lot,  selection  of  individuals  to  create  a  new seed  lot.  It’s  an

Figure 43: Relation card



intravarietal selection.

• Variety :  Set of plants that have close phenotypes.
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text formatters or for automatic translation to a variety of formats suitable for input to text 
formatters. A copy made in an otherwise Transparent file format whose markup, or absence of 
markup, has been arranged to thwart or discourage subsequent modification by readers is not 
Transparent. An image format is not Transparent if used for any substantial amount of text. A copy 
that is not "Transparent" is called "Opaque".

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo 
input format, LaTeX input format, SGML or XML using a publicly available DTD, and standard-
conforming simple HTML, PostScript or PDF designed for human modification. Examples of 
transparent image formats include PNG, XCF and JPG. Opaque formats include proprietary formats
that can be read and edited only by proprietary word processors, SGML or XML for which the DTD
and/or processing tools are not generally available, and the machine-generated HTML, PostScript or
PDF produced by some word processors for output purposes only.

The "Title Page" means, for a printed book, the title page itself, plus such following pages as are 
needed to hold, legibly, the material this License requires to appear in the title page. For works in 
formats which do not have any title page as such, "Title Page" means the text near the most 
prominent appearance of the work's title, preceding the beginning of the body of the text.

The "publisher" means any person or entity that distributes copies of the Document to the public.

A section "Entitled XYZ" means a named subunit of the Document whose title either is precisely 
XYZ or contains XYZ in parentheses following text that translates XYZ in another language. (Here 
XYZ stands for a specific section name mentioned below, such as "Acknowledgements", 
"Dedications", "Endorsements", or "History".) To "Preserve the Title" of such a section when you 
modify the Document means that it remains a section "Entitled XYZ" according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that this License 
applies to the Document. These Warranty Disclaimers are considered to be included by reference in 
this License, but only as regards disclaiming warranties: any other implication that these Warranty 
Disclaimers may have is void and has no effect on the meaning of this License.

2. VERBATIM COPYING

You may copy and distribute the Document in any medium, either commercially or 
noncommercially, provided that this License, the copyright notices, and the license notice saying 
this License applies to the Document are reproduced in all copies, and that you add no other 
conditions whatsoever to those of this License. You may not use technical measures to obstruct or 
control the reading or further copying of the copies you make or distribute. However, you may 
accept compensation in exchange for copies. If you distribute a large enough number of copies you 
must also follow the conditions in section 3.
You may also lend copies, under the same conditions stated above, and you may publicly display 
copies.

3. COPYING IN QUANTITY

If you publish printed copies (or copies in media that commonly have printed covers) of the 
Document, numbering more than 100, and the Document's license notice requires Cover Texts, you 
must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover 
Texts on the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly 
and legibly identify you as the publisher of these copies. The front cover must present the full title 
with all words of the title equally prominent and visible. You may add other material on the covers 



in addition. Copying with changes limited to the covers, as long as they preserve the title of the 
Document and satisfy these conditions, can be treated as verbatim copying in other respects.
If the required texts for either cover are too voluminous to fit legibly, you should put the first ones 
listed (as many as fit reasonably) on the actual cover, and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must 
either include a machine-readable Transparent copy along with each Opaque copy, or state in or 
with each Opaque copy a computer-network location from which the general network-using public 
has access to download using public-standard network protocols a complete Transparent copy of the
Document, free of added material. If you use the latter option, you must take reasonably prudent 
steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent 
copy will remain thus accessible at the stated location until at least one year after the last time you 
distribute an Opaque copy (directly or through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before 
redistributing any large number of copies, to give them a chance to provide you with an updated 
version of the Document.

4. MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the conditions of sections 2
and 3 above, provided that you release the Modified Version under precisely this License, with the 
Modified Version filling the role of the Document, thus licensing distribution and modification of 
the Modified Version to whoever possesses a copy of it. In addition, you must do these things in the 
Modified Version:

• A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document,
and from those of previous versions (which should, if there were any, be listed in the History
section of the Document). You may use the same title as a previous version if the original 
publisher of that version gives permission.

• B. List on the Title Page, as authors, one or more persons or entities responsible for 
authorship of the modifications in the Modified Version, together with at least five of the 
principal authors of the Document (all of its principal authors, if it has fewer than five), 
unless they release you from this requirement.

• C. State on the Title page the name of the publisher of the Modified Version, as the 
publisher.

• D. Preserve all the copyright notices of the Document.
• E. Add an appropriate copyright notice for your modifications adjacent to the other 

copyright notices.
• F. Include, immediately after the copyright notices, a license notice giving the public 

permission to use the Modified Version under the terms of this License, in the form shown 
in the Addendum below.

• G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts
given in the Document's license notice.

• H. Include an unaltered copy of this License.
• I. Preserve the section Entitled "History", Preserve its Title, and add to it an item stating at 

least the title, year, new authors, and publisher of the Modified Version as given on the Title 
Page. If there is no section Entitled "History" in the Document, create one stating the title, 
year, authors, and publisher of the Document as given on its Title Page, then add an item 
describing the Modified Version as stated in the previous sentence.

• J. Preserve the network location, if any, given in the Document for public access to a 
Transparent copy of the Document, and likewise the network locations given in the 
Document for previous versions it was based on. These may be placed in the "History" 
section. You may omit a network location for a work that was published at least four years 
before the Document itself, or if the original publisher of the version it refers to gives 



permission.
• K. For any section Entitled "Acknowledgements" or "Dedications", Preserve the Title of the 

section, and preserve in the section all the substance and tone of each of the contributor 
acknowledgements and/or dedications given therein.

• L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their 
titles. Section numbers or the equivalent are not considered part of the section titles.

• M. Delete any section Entitled "Endorsements". Such a section may not be included in the 
Modified Version.

• N. Do not retitle any existing section to be Entitled "Endorsements" or to conflict in title 
with any Invariant Section.

• O. Preserve any Warranty Disclaimers.
If the Modified Version includes new front-matter sections or appendices that qualify as Secondary 
Sections and contain no material copied from the Document, you may at your option designate 
some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections 
in the Modified Version's license notice. These titles must be distinct from any other section titles.
You may add a section Entitled "Endorsements", provided it contains nothing but endorsements of 
your Modified Version by various parties—for example, statements of peer review or that the text 
has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words 
as a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only one 
passage of Front-Cover Text and one of Back-Cover Text may be added by (or through 
arrangements made by) any one entity. If the Document already includes a cover text for the same 
cover, previously added by you or by arrangement made by the same entity you are acting on behalf
of, you may not add another; but you may replace the old one, on explicit permission from the 
previous publisher that added the old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use their 
names for publicity for or to assert or imply endorsement of any Modified Version.

5. COMBINING DOCUMENTS

You may combine the Document with other documents released under this License, under the terms
defined in section 4 above for modified versions, provided that you include in the combination all 
of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant 
Sections of your combined work in its license notice, and that you preserve all their Warranty 
Disclaimers.
The combined work need only contain one copy of this License, and multiple identical Invariant 
Sections may be replaced with a single copy. If there are multiple Invariant Sections with the same 
name but different contents, make the title of each such section unique by adding at the end of it, in 
parentheses, the name of the original author or publisher of that section if known, or else a unique 
number. Make the same adjustment to the section titles in the list of Invariant Sections in the license
notice of the combined work.

In the combination, you must combine any sections Entitled "History" in the various original 
documents, forming one section Entitled "History"; likewise combine any sections Entitled 
"Acknowledgements", and any sections Entitled "Dedications". You must delete all sections 
Entitled "Endorsements".

6. COLLECTIONS OF DOCUMENTS

You may make a collection consisting of the Document and other documents released under this 
License, and replace the individual copies of this License in the various documents with a single 
copy that is included in the collection, provided that you follow the rules of this License for 
verbatim copying of each of the documents in all other respects.



You may extract a single document from such a collection, and distribute it individually under this 
License, provided you insert a copy of this License into the extracted document, and follow this 
License in all other respects regarding verbatim copying of that document.

7. AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and independent documents or
works, in or on a volume of a storage or distribution medium, is called an "aggregate" if the 
copyright resulting from the compilation is not used to limit the legal rights of the compilation's 
users beyond what the individual works permit. When the Document is included in an aggregate, 
this License does not apply to the other works in the aggregate which are not themselves derivative 
works of the Document.
If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the 
Document is less than one half of the entire aggregate, the Document's Cover Texts may be placed 
on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if 
the Document is in electronic form. Otherwise they must appear on printed covers that bracket the 
whole aggregate.

8. TRANSLATION

Translation is considered a kind of modification, so you may distribute translations of the Document
under the terms of section 4. Replacing Invariant Sections with translations requires special 
permission from their copyright holders, but you may include translations of some or all Invariant 
Sections in addition to the original versions of these Invariant Sections. You may include a 
translation of this License, and all the license notices in the Document, and any Warranty 
Disclaimers, provided that you also include the original English version of this License and the 
original versions of those notices and disclaimers. In case of a disagreement between the translation 
and the original version of this License or a notice or disclaimer, the original version will prevail.
If a section in the Document is Entitled "Acknowledgements", "Dedications", or "History", the 
requirement (section 4) to Preserve its Title (section 1) will typically require changing the actual 
title.

9. TERMINATION

You may not copy, modify, sublicense, or distribute the Document except as expressly provided 
under this License. Any attempt otherwise to copy, modify, sublicense, or distribute it is void, and 
will automatically terminate your rights under this License.
However, if you cease all violation of this License, then your license from a particular copyright 
holder is reinstated (a) provisionally, unless and until the copyright holder explicitly and finally 
terminates your license, and (b) permanently, if the copyright holder fails to notify you of the 
violation by some reasonable means prior to 60 days after the cessation.

Moreover, your license from a particular copyright holder is reinstated permanently if the copyright 
holder notifies you of the violation by some reasonable means, this is the first time you have 
received notice of violation of this License (for any work) from that copyright holder, and you cure 
the violation prior to 30 days after your receipt of the notice.

Termination of your rights under this section does not terminate the licenses of parties who have 
received copies or rights from you under this License. If your rights have been terminated and not 
permanently reinstated, receipt of a copy of some or all of the same material does not give you any 
rights to use it.

10. FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU Free Documentation 
License from time to time. Such new versions will be similar in spirit to the present version, but 



may differ in detail to address new problems or concerns. See https://www.gnu.org/licenses/.
Each version of the License is given a distinguishing version number. If the Document specifies that
a particular numbered version of this License "or any later version" applies to it, you have the 
option of following the terms and conditions either of that specified version or of any later version 
that has been published (not as a draft) by the Free Software Foundation. If the Document does not 
specify a version number of this License, you may choose any version ever published (not as a 
draft) by the Free Software Foundation. If the Document specifies that a proxy can decide which 
future versions of this License can be used, that proxy's public statement of acceptance of a version 
permanently authorizes you to choose that version for the Document.

11. RELICENSING

"Massive Multiauthor Collaboration Site" (or "MMC Site") means any World Wide Web server that 
publishes copyrightable works and also provides prominent facilities for anybody to edit those 
works. A public wiki that anybody can edit is an example of such a server. A "Massive Multiauthor 
Collaboration" (or "MMC") contained in the site means any set of copyrightable works thus 
published on the MMC site.
"CC-BY-SA" means the Creative Commons Attribution-Share Alike 3.0 license published by 
Creative Commons Corporation, a not-for-profit corporation with a principal place of business in 
San Francisco, California, as well as future copyleft versions of that license published by that same 
organization.

"Incorporate" means to publish or republish a Document, in whole or in part, as part of another 
Document.

An MMC is "eligible for relicensing" if it is licensed under this License, and if all works that were 
first published under this License somewhere other than this MMC, and subsequently incorporated 
in whole or in part into the MMC, (1) had no cover texts or invariant sections, and (2) were thus 
incorporated prior to November 1, 2008.

The operator of an MMC Site may republish an MMC contained in the site under CC-BY-SA on the
same site at any time before August 1, 2009, provided the MMC is eligible for relicensing.

https://www.gnu.org/licenses/
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