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A Introduction
En 2005,  une collaboration a  été  initiée entre  l'Institut  National  de  la  Recherche Agronomique
(INRA) et des organisations de paysans comme le Réseau Semences Paysannes (RSP). Le but était
(1) d'étudier la gestion de la diversité cultivée à la ferme  (2) de mettre en place un programme de
sélection  participative  impliquant  les  paysans  et  les  chercheurs,  pour  développer  des  variétés-
populations adaptées à l'Agriculture Biologique (AB).

Dans ce projet, les chercheurs ont besoin de tracer l'histoire des lots de semence formant ainsi des
réseaux. Les reproductions, sélections, croisements ou les diffusions de lots de semences produisent
des données de phénotypage ou de pratiques culturales. Toutes ces informations ont besoin d'être
centralisées et stockées.

Nous avons donc développé SHiNeMaS (Seeds History and Network Management System) une
base de données et son interface web, dédiée à la gestion de l'histoire des lots de semences et aux
données associées.

B Administration

B.1 Gestion des utilisateurs

B.1.a Créer/Modifier/Supprimer un utilisateur

Pour gérer les utilisateurs de l’application, se rendre dans le menu Admin data > Actors & Users >
Users. Cet écran récapitule les utilisateurs déjà existants (Figure 1).

Pour créer un nouvel utilisateur cliquer sur ‘Add User’, le formulaire (Figure 2) demande dans un
premier temps l’identifiant et la mot de passe du futur utilisateur. Cliquer sur ‘Save’ et finaliser dans
un second formulaire la création de l’utilisateur en saisissant les informations nécessaires (Prénom,
Nom, adresse mail). Si un utilisateur est destiné a être administrateur cocher les cases ‘staff status’
et ‘superuser status’.

Pour éditer  un utilisateur,  depuis l’écran récapitulatif,  cliquer  sur son identifiant.  Le formulaire
suivant permet de modifier toutes les informations relatives à un utilisateur. Cliquer sur ‘Save’ pour
valider les modifications. Pour réinitialiser le mot de passe d’un utilisateur suivre le lien ‘this form’
dans  la  section  ‘Password’ du  formulaire.  Pour  supprimer  un  utilisateur  cliquer  sur  le  bouton
‘Delete’ en bas à gauche du formulaire puis confirmer la suppression sur l’écran suivant.

Figure 1: Liste des utilisateurs



B.1.b Statut des utilisateurs

Un utilisateur peut avoir deux statuts dans SHiNeMaS : administrateur ou lecture seule. Lors de la
création/édition d’un utilisateur administrateur il est important de cocher les deux cases ‘staff status’
et  ‘superuser  status’  (Figure  1)  afin  qu’un  administrateur  puisse  utiliser  pleinement  les
fonctionnalités  d’administration.  La  fonctionnalité  ‘superuser’  donne  la  possibilité  de
créer/modifier/supprimer toutes données dans la base. La fonctionnalité ‘staff’ permet d’accéder à la
partie ‘admin’ de l’interface de SHiNeMaS (par lien situé haut à droite). Les deux cases doivent
donc être décochées pour créer un utilisateur en lecture seule.

B.2 Gestion des projets et des acteurs

B.2.a Gestion des projets

Pour gérer les projets de l’application se rendre dans le menu Admin data > Actors & Users >
Projects. Cet écran récapitule les projets déjà existants.

Pour créer un nouveau projet cliquer sur ‘Add project’, le formulaire demande un nom de projet et
la date de début du projet. Cliquer sur ‘Save’ pour valider sa création.

Pour éditer un projet, depuis l’écran récapitulatif, cliquer sur son nom. Le formulaire suivant permet
de  modifier  toutes  les  informations  relatives  à  un  projet.  Cliquer  sur  ‘Save’ pour  valider  les
modifications.

Pour  supprimer  un  projet  cliquer  sur  le  bouton  ‘Delete’ en  bas  à  gauche  du  formulaire  puis
confirmer la suppression sur l’écran suivant.

Figure 2: Formulaire de création d'un utilisateur



B.2.b Gestion des acteurs du réseau (Person)

Les ‘person’ ou acteurs du réseau représentent les personnes physiques qui sont amenées à produire

des données stockées dans la base sans pour autant posséder de compte utilisateur. Pour gérer les
‘person’ de l’application se rendre dans le menu Admin data > Actors & Users > Persons. Cet écran
récapitule les acteurs déjà existants.

Pour créer un nouvel acteur cliquer sur ‘Add person’, le formulaire (Figure 3) demande un prénom
et un nom ainsi qu’un identifiant court utilisé dans les différents écran de l’application. En cliquant
sur le lien ‘Show’ une deuxième partie de formulaire apparaît dans laquelle les informations de
contact de l’acteur peuvent être renseignées. Cliquer sur ‘Save’ pour valider sa création.

Pour éditer une personne, depuis l’écran récapitulatif,  cliquer sur son nom court.  Le formulaire
suivant permet de modifier toutes les informations relatives à une personne. Cliquer sur ‘Save’ pour
valider les modifications.

Pour supprimer une personne cliquer sur le bouton ‘Delete’ en bas à gauche du formulaire puis
confirmer la suppression sur l’écran suivant.

Figure 3: Formulaire de création d'une personne



B.2.c Gestion des lieux/fermes (Location)

Pour gérer  les  lieux de l’application se rendre  dans  le  menu Admin data  > Actors  & Users  >
Locations. Cet écran récapitule les lieux déjà existants.

Pour créer un nouveau lieux cliquer sur ‘Add location’, le formulaire (Figure 4) demande un nom

de lieux et différentes informations de localisation ainsi que (obligatoire) un nom court pour ce
lieux.  Ce  nom court  est  important  c’est  celui  qui  est  utilisé  dans  le  chapitre  « Règles  sur  la
nomenclature des lots de graines ». Cliquer sur ‘Save’ pour valider sa création.

Pour éditer un lieux, depuis l’écran récapitulatif, cliquer sur son nom. Le formulaire suivant permet
de modifier toutes les informations relatives à un lieux excepté le nom court. Cliquer sur ‘Save’
pour valider les modifications.

Pour supprimer un lieux cliquer sur le bouton ‘Delete’ en bas à gauche du formulaire puis confirmer
la suppression sur l’écran suivant.

B.3 Gestion des entités biologiques

B.3.a Gestion des espèces

Pour gérer les espèces déclarées dans SHiNeMaS, se rendre dans le menu Admin data > Biological
Entities > Species. Cet écran récapitule les espèces déjà existantes.

Pour  créer  une  nouvelle  espèce  cliquer  sur  ‘Add  species’,  le  formulaire  demande  un  nom de
l’espèce (champ ‘species’)  ainsi  que son nom latin  et  une description (optionnels).  Cliquer  sur

Figure 4: Formulaire de création d'un lieu



‘Save’ pour valider sa création.

Pour éditer une espèce,  depuis l’écran récapitulatif,  cliquer sur son nom. Le formulaire suivant
permet de modifier toutes les informations relatives à une espèce. Cliquer sur ‘Save’ pour valider
les modifications.

Pour  supprimer  une  espèce  cliquer  sur  le  bouton ‘Delete’ en  bas  à  gauche du formulaire  puis
confirmer la suppression sur l’écran suivant.

B.3.b Gestion des types de variété

Pour  gérer  les  types  de  variétés  se  rendre  dans  le  menu  Admin  data  >  Biological  Entities >
Germplasm Type.

Pour créer un nouveau type de variétés, cliquer sur ‘Add germplasm_type’, le formulaire demande
le nom du type ainsi qu’une description (optionnelle). Cliquer sur ‘Save’ pour valider sa création.

Pour éditer un type de  variétés, depuis l’écran récapitulatif,  cliquer sur son nom. Le formulaire
suivant permet de modifier toutes les informations relatives à ce type de variétés. Cliquer sur ‘Save’
pour valider les modifications.

Pour supprimer un type de variétés cliquer sur le bouton ‘Delete’ en bas à gauche du formulaire puis
confirmer la suppression sur l’écran suivant.

B.3.c Gestion des variétés

Pour gérer les variétés se rendre dans le menu Admin data > Biological Entities > Germplasm.

Pour créer une nouvelle variété cliquer sur ‘Add germplasm’, le formulaire demande un nom de
variété, il est également possible de renseigner le type de la variété, son espèce (recommandé), ainsi
que la personne ayant créé cette variété si connue. Cliquer sur ‘Save’ pour valider sa création.

Pour éditer une variété,  depuis l’écran récapitulatif,  cliquer sur son nom. Le formulaire suivant
permet de modifier toutes les informations relatives à une variété excepté son nom. Le nom d’une
variété n’est pas éditable car cette modification aurait un impact direct sur le nom de tous les lots de
graines de cette variété comme décrit dans le chapitre « Règles sur la nomenclature des lots de
graines ». Cliquer sur ‘Save’ pour valider les modifications.

Pour  supprimer  une  variété  cliquer  sur  le  bouton ‘Delete’ en bas  à  gauche du formulaire  puis
confirmer la suppression sur l’écran suivant.

B.3.d Gestion des lots de graines

Pour gérer les lots de graines se rendre dans le menu Admin data > Biological Entities > Seed lot.

Il n’est pas possible via les interfaces d’administration de créer de nouveaux lots de graines. Les
nouveaux lots de graines sont principalement créés lors de la création de nouveaux événements
(voir Gestion des réseaux et de l'histoire des lots de graines).

Pour éditer un lot de graines, depuis l’écran récapitulatif, cliquer sur son nom. Le formulaire suivant
permet de modifier certaines informations relatives à un lot de graines. Cependant, son nom, sa
variété, son année de création ainsi que le lieu du lot ne peuvent être modifié car la modification de
ces  informations  auraient  un  impact  direct  sur  l’ensemble  de  l’histoire  descendante  du  lot  de
graines. Les informations de génération peuvent être éditées, les générations des lots de graines
ascendants ou descendants en sont pas recalculées. Il appartient donc à l’utilisateur d’être prudent
lors de l’édition de cette donnée. Cliquer sur ‘Save’ pour valider les modifications.

Pour supprimer un lot de graines cliquer sur le bouton ‘Delete’ en bas à gauche du formulaire puis
confirmer la suppression sur l’écran suivant.



B.4 Gestion des réseaux et de l'histoire des lots de graines

B.4.a Gestion des méthodes de reproduction

Pour gérer les méthodes de reproduction se rendre dans le menu Admin data > Data Descriptors >
Repro. method.

Pour  créer  une  nouvelle  méthode  de  reproduction  cliquer  sur  ‘Add  reproduction_method’,  le
formulaire demande le nom de la méthode ainsi qu’une description (optionnelle). Cliquer sur ‘Save’
pour valider sa création.

Pour éditer  une méthode de reproduction,  depuis  l’écran  récapitulatif,  cliquer  sur  son nom. Le
formulaire suivant permet de modifier toutes les informations relatives à cette méthode. Cliquer sur
‘Save’ pour valider les modifications.

Pour supprimer une méthode de reproduction cliquer sur le bouton ‘Delete’ en bas à gauche du
formulaire puis confirmer la suppression sur l’écran suivant.

B.4.b Gestion des méthodes liées aux mesures

Pour gérer les méthodes de mesure se rendre dans le menu Admin data > Data Descriptors > Data
method.

Pour créer une nouvelle méthode de mesure cliquer sur ‘Add method’, le formulaire demande le
nom  de  la  méthode  ainsi  qu’une  description,  l’unité  de  mesure  et  d’autres  informations
(optionnelles). Cliquer sur ‘Save’ pour valider sa création.

Pour éditer une méthode de mesure, depuis l’écran récapitulatif, cliquer sur son nom. Le formulaire
suivant permet de modifier toutes les informations relatives à cette méthode. Cliquer sur ‘Save’
pour valider les modifications.

Pour supprimer une méthode de mesure cliquer sur le bouton ‘Delete’ en bas à gauche du formulaire
puis confirmer la suppression sur l’écran suivant.

B.4.c Préparation des fichiers

B.4.c.i Format des fichiers de soumission

Les fichiers de soumission de SHiNeMaS sont du type « tableur » et doivent respecter, à minima,
les règles suivantes :

• Format texte1

• Séparateur de colonne : tabulation

• Délimiteur de texte : "

Par  exemple,  un  fichier  ouvert  avec  un éditeur  de  texte  simple,  et  destiné  a  être  soumis  dans
SHiNeMaS doit avoir cet aspect :

"project" "location" "id_seed_lot" "etiquette" "event_year" "split" "quantity"

"PPB" "FLM" "Rouge-du-Roc_JFB_2004_0001" 2004 1 250

"PPB" "FLM" "Clomone_JFB_2004_0001" 2004 1 122

Chaque type de fichier est décrit par des champs fixes qui lui sont propres (entêtes des colonnes). Il
est possible d'ajouter des colonnes supplémentaires en utilisant le fichier des méthodes (chapitre
B.4.c.ii),  cette  fonctionnalité  permet  à  l'utilisateur  de  personnaliser  la  définition  des  variables

1 Les fichiers possédant une extension .xls ou .ods ne sont pas des fichiers textes. Il faut exporter les données au 
format CSV depuis Excel ou LibreOffice par exemple, pour obtenir un format texte (se référer à l'aide de ces outils 
pour exporter au format csv)



mesurées.

B.4.c.ii Fichier des méthodes

Description

Le fichier des méthodes contient la description des mesures réalisées et des méthodes utilisées pour
réaliser ces mesures. Quatre champs décrivent ce fichier :

• variable : le nom de la variable qui est mesurée

• type :  le  type  associé  à  la  variable  (les  types  de  variables  sont  décrit  dans  la  rubrique
suivante)

• method_name : le nom de la méthode associée à la mesure de la variable

• correlation_group : le(s) groupe(s) de corrélation auquel(s) appartient la variable qui est
mesurée (Les groupes de corrélation sont décrit dans ce chapitre, après la rubrique « Types
de variables »)

Types de variables

Les  mesures  réalisées  possèdent  un  champ  d'application  qui  peut  varier  selon  le  contexte.  Le
Tableau 1 décrit les différents champs d'application des mesures.

Type Champ d'application 
Type 1 Quelque soit le type d'événement la mesure est liée à toutes les 

relations
Type 2 Dans le cas d'un croisement la mesure est liée à la relation mâle
Type 3 Dans le cas d'un croisement la mesure est liée à la relation 

femelle
Type 4 Dans le cas d'une multiplication la mesure ne s'applique qu'à la 

relation de sélection
Type 5 Dans le cas d'un mélange la mesure ne s'applique qu'à une 

relation particulière du mélange
Type 6 Dans le cas d'une multiplication la mesure ne s'applique qu'au 

vrac (ce qui n'est pas de la sélection)
Type 7 La mesure s'applique au lot de graine parent de la relation
Type 8 La mesure s'applique au lot de graine enfant de la relation
Type 9 Dans le cas d'un croisement la mesure ne s'applique qu'au lot de 

graine mâle
Type 10 Dans le cas d'un croisement la mesure ne s'applique qu'au lot de 

graine femelle
Type 11 Mesure qui ne s'applique qu'à un individu

Tableau 1: Définition des différents types de variables

Groupes de corrélation

Les groupes de corrélation concernent les mesures qui sont réalisées sur des individus qui sont
numérotés.  Au cours d’une série de mesure (à une même date  par exemple) les individus sont
numérotés.  Lors de la  série  de mesure suivante (à une autre  date  par exemple)  deux scénarios
peuvent survenir :

• La numérotation des individus n’a pas été conservée. Autrement dit les mesures réalisées
dans la première série et dans le deuxième série ne peuvent être associées et ne devraient pas
appartenir au même groupe de corrélation (i.e. des corrélations entre ces variables pour un
individu donné n’est pas possible).



• La numérotation des individus a été conservée. Dans ce cas les mesures devraient appartenir
au même groupe de corrélation (i.e. des corrélations entre ces variables pour un individu
donné est possible).

La colonne  correlation_group,  présente  dans  le  fichier  méthode et  dans  le  fichier  de données

individuelles, permet de définir les différents groupes de corrélations.

Dans l'exemple (Figure 5), le fichier de données individuelles définit quatre groupes de corrélation
(le groupe A en jaune, le groupe B en vert, le groupe C en mauve et le groupe D en saumon).

L'individu  6  est  concerné  par  les  groupes  B,  C,  D  comme  indiqué  dans  la  colonne
correlation_group. Cependant ce fichier n'indique pas quelles sont les variables concernées par tel
ou tel  groupe (les couleurs utilisées ne servent qu'à illustrer l'exemple et  ne sont pas prises en
compte  par  SHiNeMaS).  Le  fichier  méthodes  (Figure  6)  permet  de  palier  à  ce  problème.  Par
exemple,  la variable  phenotypic_notes  appartient aux groupes A et B. SHiNeMaS sera donc en

Figure 5: Fichier de données individuelles - groupes de corrélation

Figure 6: Fichier méthodes - groupes de corrélation



mesure de savoir  que pour les individus 1 à 5,  la mesure de  phenotypic_notes  sera affectée au
groupe A, pour les individus 6 à 24 au groupe B.

Cas particulier

Il est possible de mesurer une même variable en utilisant deux méthodes différentes. Pour cela la
variable  devra  être  identifiée  par  un préfixe  dans  le  fichier  des  données  et  dans  le  fichier  des
méthodes. La syntaxe (illustrée dans la Figure 7) utilisée est la suivante :

préfixe%nom_de_la_variable

B.4.c.iiiRègles sur la nomenclature des lots de graines

Cas des lots de graines existant dans la base de données

Une nomenclature a été définie dans SHiNeMaS pour assurer l'unicité des noms des lots de graines
dans la base de données. Celle-ci se base sur 3 informations : Le nom de la variété (VARIETE),
l'année de création du lot de graines (ANNEE), le lieux de ce lot de graines (LOCATION). On peut
tout à fait imaginer qu'une même variété ait donné lieu à plusieurs lots de graines une même année
dans un même lieu. Ainsi une quatrième information est utilisée : une numérotation à 4 chiffres
(NUM) assurant l'unicité du nom d'un lot de graines.

Les informations sont séparées par le caractère '_' (underscore ou tiret bas). Celui ci est donc interdit
pour définir le nom d'une variété ou le nom court d'une personne.

Le nom d'un lot de graine se décrit ainsi :

VARIETE_ANNEE_PERSON_NUM

Cas des lots de graines n'existant pas dans la base de données

Ce cas de figure se présente lorsqu'un lot de graines intègre le réseau d'histoire de vie des semences
bien qu'il ne soit jamais apparu dans le réseau auparavant. Dans ce cas l'utilisateur doit renseigner
les informations suivantes dans les cases correspondant à l'identifiant du lot de graines :

VARIETE_ANNEE_PERSON

L'application calculera automatiquement l'extension à 4 chiffres nécessaire pour (1) assurer l'unicité
du nom du lot de graines et (2) respecter la nomenclature définie dans SHiNeMaS. Dans le cas où la
variété VARIETE n'existe pas dans la base de données, celle-ci est créée automatiquement.

Il  est  important  de  signaler  qu'il  est  possible  d'utiliser  plusieurs  fois  la  même  structure
VARIETE_ANNEE_PERSON dans un même fichier. L'application considérera qu'il s'agit du même
lot de graines utilisé plusieurs fois.

Figure 7: Utilisation du préfixe pour définir une variable mesurée par deux 
méthodes



Cas des sélections

Lorsqu'une sélection est réalisée (chapitre B.4.c.viii) le nom du lot de graines est alors soumis une
nomenclature spécifique incluant le nom de la sélection (SEL) :

VARIETE#SEL_ANNEE_PERSON_NUM

Le caractère '#'  (diez) est utilisé pour associer le nom de la variété au nom de la sélection. Ce
caractère ne peut donc pas être utilisé dans le nom des variétés. L'expression  VARIETE#SEL sera
transmise à tous les lots de graines descendant lorsqu'il s'agit d'une reproduction ou d'une diffusion.
Si une nouvelle sélection (NSEL) est réalisée sur un lot de graines descendant, l'expression SEL est
alors remplacée par NSEL comme suit :

VARIETE#NSEL_ANNEE_PERSON_NUM

Un mélange ou un croisement donnant lieu à la création d'une nouvelle variété, l'information du
nom de sélection disparaît et le nom du lot de graines respecte une nomenclature classique décrite
dans le premier paragraphe.

B.4.c.ivFichier de croisement

Objectif

Ce fichier permet de créer des événements de croisements entre des variétés distinctes, comme
représentés sur la Figure 8. Un croisement donne lieu à la création d'une nouvelle variété.

Structure du fichier

Le fichier de croisement décrit les informations nécessaires pour créer un événement de croisement 
dans la base de données. Les champs nécessaire pour créer un croisement sont les suivants :

• project : Projet dans lequel l'événement a lieu

• sown_year : Année de semis des lots de graines parents 

• harvested_year : Année de récolte du lot de graine issu du croisement

• quantity_harvested : Quantité récoltée après le croisement. Il s'agira de la quantité initiale 
du lot de graines récolté

• cross_year : Année du croisement

• cross_germplasm : Nom de la variété créée

• number_crosses : Nombre de croisements réalisés. 

Figure 8: Représentation d'un croisement



• kernel_number_F1 : Nombre de graines issues du croisement et utilisées pour la F1

• male_seed_lot : Identifiant du lot de graine utilisé comme mâle

• male_etiquette : Étiquette utilisée pour le lot de graines mâle

• male_split : Indique si la totalité du lot de graines mâle a été utilisée lors du croisement : 0 
pour la totalité et 1 sinon 

• male_quantity : Quantité du lot de graines mâle utilisée

• male_block : Bloc dans lequel le lot de graines mâle a été semé

• male_X : Coordonnée X du lot de graines mâle

• male_Y : Coordonnée Y du lot de graines mâle

• female_seed_lot : Identifiant du lot de graine utilisé comme femelle

• female_etiquette : Étiquette utilisée pour le  lot de graines femelle

• female_split : Indique si la totalité du lot de graines femelle a été utilisé lors du croisement :
0 pour la totalité et 1 sinon 

• female_quantity : Quantité du lot de graines femelle utilisée

• female_block : Bloc dans lequel le lot de graines femelle a été semé

• female_X : Coordonnée X du lot de graines femelle

• female_Y : Coordonnée Y du lot de graines femelle

Générer un fichier automatiquement

Pour préparer un fichier de croisement se rendre dans le menu Prepare & Upload File > Prepare
Files > Cross.

Une interface de recherche simplifiée (Figure 9) propose de rechercher des lot  de graines  déjà

Figure 9: Formulaire  de recherche simplifié



renseignés dans la base de données selon 3 critères : année de création, projets dans lesquels ils sont
utilisés, lieu sur laquelle ils sont stockés.

Une liste s’affiche (Figure 10) avec deux icônes ( ) qui permettent par un simple clic d’ajouter
le lots de graines à une liste de lots qui seront utilisés en tant que mâle ou femelle. Cette liste est
visible en cliquant sur l’icône située sur la droite de la liste de résultats. Les lots sont groupés
par  deux  (mâle/femelle).  Cette  action  fait  apparaître  une  fenêtre  qui  permet  soit  d’effacer  des
couples de lots de graines de la liste ou compléter les informations de préparation du fichier.

Un clic sur le bouton ‘Export File’ permet de télécharger le fichier de croisement pré-remplit. Un
utilisateur peut également modifier les filtres de recherche et la relancer afin de compléter sa liste de

lots de graines.

B.4.c.v Fichier de diffusion

Objectif

Ce fichier permet de créer des événements de diffusion. Une diffusion permet d'envoyer un lot de
graines, en totalité ou partiellement, d'un lieu A vers un lieu B, comme représenté sur la Figure 11.

Structure du fichier

Le fichier de diffusion décrit les informations nécessaires pour créer un événement de diffusion
dans la base de données. Les champs nécessaire pour créer une diffusion sont les suivants :

• project : Projet dans lequel la diffusion a lieu

• location : Lieu sur laquelle le lot de graines est diffusé

• id_seed_lot : Identifiant du lot de graines  « parent » envoyé

Figure 10: Interface de préparation d'un fichier de croisement



• etiquette : Étiquette utilisée pour le  lot de graines « parent »

• event_year : Année de la diffusion

• split : Indique si la totalité du lot de graines « parent » a été diffusée : 0 pour la totalité et 1
sinon 

• quantity : Quantité du lot de graines diffusée (lot de graines « enfant »)

Générer un fichier automatiquement

Pour préparer un fichier de diffusion se rendre dans le menu Prepare & Upload File > Prepare Files
> Diffusion.

Une interface de recherche simplifiée (Figure 9) propose de rechercher des lot  de graines  déjà

renseignés dans la base de données selon 3 critères : année de création, projets dans lesquels ils sont
utilisés, lieu sur laquelle ils sont stockés.

Une liste s’affiche (Figure 12), il convient dans un premier temps de sélectionner le destinataire
puis par un simple clic sur l’icône d’ajouter  les  lots  de  graines  qui  seront  envoyés  à  ce
destinataire. La liste est visible en cliquant sur l’icône située  sur  la  droite  de  la  liste  de
résultats. Cette action fait apparaître une fenêtre qui permet soit d’effacer des diffusions de lots de
graines de la liste ou compléter les informations de préparation du fichier.

Figure 11: Représentation d'une diffusion



Un clic sur le bouton ‘Export File’ permet de télécharger le fichier de diffusion pré-remplit. Un
utilisateur peut également modifier les filtres de recherche et la relancer afin de compléter sa liste de

lots de graines.

B.4.c.viFichier de mélange

Objectif

Ce fichier permet de créer des événements de mélanges comme décrit sur la Figure 13. Un mélange
consiste à utiliser au moins deux lots de graines et à les regrouper en un seul lot de graines. Il n'y a
pas de limite sur le nombre de lots de graines qu'il est possible de mélanger. Cependant, tous les lots
de graines doivent provenir du même lieu. Un mélange donne lieu à la création d'une nouvelle
variété.

Figure 12: Interface de préparation d'un fichier de diffusion



Structure du fichier

Le fichier de mélange décrit les informations nécessaires pour créer un événement de mélange dans
la base de données.  Le fichier de mélange possède la particularité de décrire un événement de
mélange  sur  plusieurs  lignes  du  fichier.  Chaque  ligne  décrit  un  lot  de  graines  utilisé  dans  le
mélange. Le champ germplasm, répété sur plusieurs lignes, permet de regrouper les lots de graines
qui sont utilisés dans un même mélange. Les champs nécessaires pour créer un mélange sont les
suivants :

• project : Projet dans lequel la diffusion a lieu

• id_seed_lot : Identifiant du lot de graines « parent » mélangé

• etiquette : Étiquette utilisée pour le  lot de graines « parent »

• split : Indique si la totalité du lot de graines « parent »a été mélangée : 0 pour la totalité et 1
sinon 

• quantity : Quantité du lot de graines « parent » mélangée

• germplasm : Nom de la variété créée

• event_year : Année du mélange

Générer un fichier automatiquement

Pour préparer un fichier de mélange se rendre dans le menu Prepare & Upload File > Prepare Files
> Mixture.

Une interface de recherche simplifiée (Figure 9) propose de rechercher des lot  de graines  déjà
renseignés dans la base de données selon 3 critères : année de création, projets dans lesquels ils sont
utilisés, lieu sur laquelle ils sont stockés.

Une liste s’affiche (Figure 14), il convient dans un premier temps de saisir le nom de la variété issue
du mélange puis par un simple clic sur l’icône d’ajouter les lots de graines qui seront utilisés
dans ce mélange.  La liste est visible en cliquant sur l’icône située sur la droite de la liste de
résultats.  Cette  action  fait  apparaître  une  fenêtre  qui  permet  soit  d’effacer  des  relations  d’un
mélange de lots de graines ou compléter les informations de préparation du fichier.

Figure 13: Représentation d'un mélange



Un clic sur le bouton ‘Export File’ permet de télécharger le fichier de mélange pré-remplit.  Un
utilisateur peut également modifier les filtres de recherche et la relancer afin de compléter sa liste de

lots de graines.

B.4.c.vii Fichier de reproduction

Objectif

Ce fichier permet de créer des événements de reproduction comme décrit sur la  Figure 15. Une
reproduction  a  lieu  sur  un  lieu  donné,  à  une  position  donnée,  définie  par  son  bloc et  ses
coordonnées X et Y.

Une reproduction consiste à semer un lot de graines, à un ou plusieurs emplacements, puis à en
récolter le ou les lot de graines enfants.

Figure 14: Interface de préparation d'un fichier de mélange

Figure 15: Représentation d'une reproduction



Structure du fichier

Le  fichier  de  reproduction  décrit  les  informations  nécessaires  pour  créer  un  événement  de
reproduction dans la base de données. Les champs nécessaires pour créer une reproduction sont les
suivants :

• project : Projet dans lequel la reproduction a lieu

• sown_year : Année de semis du lot de graines « parent »

• harvested_year : Année de récolte du lot de graines « enfant »

• id_seed_lot_sown : Identifiant du lot de graines « parent » semé

• intra_selection_name : Nom de la sélection le cas échéant

• etiquette : Étiquette utilisée pour le lot de graines « parent »

• split : Indique si la totalité du lot de graines « parent » a été semé, : 0 pour la totalité et 1
sinon 

• quantity_sown : Quantité de lot de graines  « parent » utilisée

• quantity_harvested : Quantité récoltée pour le lot de graines « enfant »

• block : bloc de localisation de la reproduction

• X : coordonnée X

• Y : coordonnée Y

Générer un fichier automatiquement

Deux cas de figure peuvent se présenter pour créer un fichier de reproduction. Soit le fichier est
soumis une première fois (au semis par exemple). Dans ce cas l’utilisateur va sélectionner une liste
de  lots  de  graines  qu’il  va  semer.  Dans  le  deuxième  cas  l’utilisateur  va  soumettre  un  fichier
contenant des mesures sur des reproductions déjà existantes (un fichier de semis a déjà été soumis).
Dans ce cas l’utilisateur va sélectionner des reproductions dans une liste.

Préparer un fichier de semis

Pour préparer un fichier de reproductions à créer se rendre dans le menu Prepare & Upload File >
Prepare  Files  >  Reproduction.  Une  interface  de  recherche  simplifiée  (Figure  9)  propose  de
rechercher des lot de graines déjà renseignés dans la base de données selon 3 critères : année de
création, projets dans lesquels ils sont utilisés, lieu sur laquelle ils sont stockés. Une liste s’affiche
(Figure 16) qui permet par un simple clic sur l’icône d’ajouter  les  lots  de graines  qui  seront
utilisés dans une relation de reproduction. Cette liste est visible en cliquant sur l’icône située
sur la droite de la liste de résultats. Cette action fait apparaître une fenêtre qui permet soit d’effacer
des reproductions ou compléter les informations de préparation du fichier. 



Un clic sur le bouton ‘Export File’ permet de télécharger le fichier de reproduction pré-remplit. Un
utilisateur peut également modifier les filtres de recherche et la relancer afin de compléter sa liste de
lots de graines.

Figure 16: Interface de préparation d'un fichier de semis



Préparer un fichier de reproductions existantes

Pour préparer un fichier de reproductions existantes se rendre dans le menu Prepare & Upload File
> Prepare Files > Existing reproduction. Une interface de recherche simplifiée (Figure 9) propose
de rechercher des reproductions déjà existantes dans la base de données selon 3 critères : année de
création du lot de graines semé, projets lié à la reproduction, lieu sur laquelle la reproduction a lieu.
Une liste s’affiche (Figure 17) qui permet par un simple clic sur l’icône d’ajouter  les
reproductions à exporter dans le fichier. Les reproductions sont ici définies par le nom du lot de
graines semé et la localisation du semis. Cette liste est visible en cliquant sur l’icône située sur
la droite de la liste de résultats. Cette action fait apparaître une fenêtre qui permet soit d’effacer des

reproductions ou compléter les informations de préparation du fichier. 

Un clic sur le bouton ‘Export File’ permet de télécharger le fichier de reproduction pré-remplit. Un
utilisateur peut également modifier les filtres de recherche et la relancer afin de compléter sa liste de
reproductions.

B.4.c.viii  Fichier de sélection

Objectif

Ce fichier permet de créer des événements de sélection comme représenté dans la  Figure 18. Un
événement de sélection est toujours associé à une reproduction. Une sélection peut être réalisée par
un acteur du réseau.

Figure 17: Interface de préparation d'un fichier de reproduction en cours



Structure du fichier

Le fichier de sélection décrit les informations nécessaires pour créer un événement de sélection dans
la base de données. Les champs nécessaires pour créer une sélection sont les suivants :

• project : Projet dans lequel la sélection a lieu

• sown_year : Année de semis du lot de graines « parent »

• harvested_year : Année de récolte du lot de graines « enfant »

• id_seed_lot_sown : Identifiant du lot de graines « parent » semé

• etiquette : Étiquette utilisée pour le  lot de graines « parent »

• block : bloc de localisation de la reproduction

• X : coordonnée X

• Y : coordonnée Y

• selection_person : Nom court renseignant la personne qui a réalisé la sélection

• selection_quantity_ini : Quantité sélectionné

• selection_name : Nom donné à cette sélection

Générer un fichier automatiquement

Pour préparer un fichier de sélection se rendre dans le menu Prepare & Upload File > Prepare Files
> Intra seed lot selection.

Une interface  de  recherche  simplifiée  (Figure  9)  propose  de rechercher  des  reproductions  déjà
existantes dans la base de données selon 3 critères :  année de création du lot  de graines semé,
projets lié à la reproduction, lieu sur laquelle la reproduction a lieu.

Une liste s’affiche (Figure 19) qui permet par un simple clic sur l’icône d’ajouter  les
reproductions à exporter dans le fichier. Les reproductions sont ici définies par le nom du lot de
graines semé et la localisation du demi. Cette liste est visible en cliquant sur l’icône située  sur
la droite de la liste de résultats. Cette action fait apparaître une fenêtre qui permet soit d’effacer des
reproductions ou compléter les informations de préparation du fichier.

Figure 18: Représentation d'une sélection



Un clic sur le bouton ‘Export File’ permet de télécharger le fichier de sélection pré-remplit. Un
utilisateur peut également modifier les filtres de recherche et la relancer afin de compléter sa liste de

reproductions.

B.4.c.ixFichier de données individuelles

Objectif

Ce  fichier  permet  de  saisir  des  données  individuelles  concernant  des  reproductions  ou  des
sélections. Les données individuelles sont associées à des individus numérotés.

Structure du fichier

Le fichier de données individuelles décrit les informations nécessaires pour insérer des données de
individuelles dans la base de données. Les champs nécessaires pour insérer ces données sont les
suivants :

• project : Projet dans lequel les mesures ont eu lieu

• sown_year : Année de semis du lot de graines « parent »

• harvested_year : Année de récolte du lot de graines « enfant »

• id_seed_lot_sown : Identifiant du lot de graines « parent » semé

• intra_selection_name : Nom de la sélection le cas échéant

• sown_etiquette : Étiquette utilisée pour le lot de graines « parent » semé

• id_seed_lot_harvested :  Identifiant du lot de graines « enfant » récolté

• harvested_etiquette : Étiquette utilisée pour le lot de graines « enfant » récolté

• block : bloc de localisation de la reproduction

Figure 19: Interface de préparation d'un fichier de sélection



• X : coordonnée X

• Y : coordonnée Y

• individuals : Numéro de l'individu

Générer un fichier automatiquement

Pour préparer un fichier de données individuelles se rendre dans le menu Prepare & Upload File >
Prepare Files > Individual data.

Une interface  de  recherche  simplifiée  (Figure  9)  propose  de rechercher  des  reproductions  déjà
existantes dans la base de données selon 3 critères :  année de création du lot  de graines semé,
projets lié à la reproduction, lieu sur laquelle la reproduction a lieu.

Une liste s’affiche (Figure 20) qui permet par un simple clic sur l’icône d’ajouter  les
reproductions à exporter dans le fichier. Les reproductions sont ici définies par le nom du lot de

graines semé et la localisation du semis. Cette liste est visible en cliquant sur l’icône  située sur la
droite de la liste de résultats. Cette action fait apparaître une fenêtre qui permet soit d’effacer des
reproductions ou compléter les informations de préparation du fichier.

Un clic sur le bouton ‘Export File’ permet de télécharger le fichier de données individuelles pré-
remplit.  Un  utilisateur  peut  également  modifier  les  filtres  de  recherche  et  la  relancer  afin  de
compléter sa liste de reproductions.

B.4.c.x Caractères interdits dans les différents champs de SHiNeMaS

Information Liste des caractères interdits
Nom des variétés #, _, espace
Nom court des personnes #, _, espace
Nom des variables %

Tableau 2: Récapitulatif des caractères interdits dans les différents champs de SHiNeMaS

Figure 20: Interface de préparation d'un fichier de données individuelles



B.4.d Soumission du fichier

B.4.d.i Interface de soumission des fichiers

Dans Import/Export > Upload, choisir un fichier de données dans le champs « File », un fichier de
méthodes dans le champs « Method ». Sélectionner le bon type de fichier parmi : Cross, Diffusion,
Mixture, Multiplication, Intra varietal selection ou Individual. Cliquer sur « Submit ».

B.4.d.ii Traitements particuliers lors de la soumission d'un fichier

Traitements particuliers communs à tous les fichiers

• Lorsque le champs project indique un projet qui n'existe pas celui ci est automatiquement
créé par l'application

• Les lots de graines inexistants dans la base de données sont traités comme décrit dans le
chapitre 'Cas des lots de graines n'existant pas dans la base de données'

Cas des croisements

• Dans le cas d'un  number_crosses égal à 0 l'application génère un lot de graines virtuel
nommé selon la nomenclature NOTCROSSED_NUM, NUM assurant son unicité.

• Dans le cas d'un kernel_number_F1 égal à 0 l'application génère un lot de graines virtuel
nommé selon la nomenclature NOTCROSSED_NUM, NUM assurant son unicité.

Cas des reproductions

• Lorsqu’une reproduction est en cours à un emplacement donné (même lieu, X, Y) vous ne
pouvez pas y semer un lot de graines d'une même espèce.

• En revanche vous pouvez ajouter des données à une reproduction en cours. La reproduction
sera identifié par un même lot de graines semé à un même emplacement.

Figure 21: Interface de soumission des fichiers



Cas des sélections

• Une sélection est toujours associée à une reproduction (identifiée par le lot de graines semé,
et son emplacement). Toutefois si un événement de sélection est renseigné dans un fichier
mais qu'aucune reproduction ne correspond, l'application créera une nouvelle reproduction.

• Un nom de sélection ne peut être utilisé qu’une fois pour une variété

Cas des données individuelles

• Les reproductions déclarées dans le fichier de données individuelles doivent exister

B.4.e Rapports de soumission

B.4.e.i Soumission avec succès

Après  chaque  soumissions  un  rapport  indique  les  informations  qui  ont  été  nouvellement  créés
(Figure 22) dans la base de données. Ces informations sont de plusieurs natures et indiquent :

• Les nouvelles variables qui ont été créées

• Les nouvelles variétés qui ont été créées

• Les nouveaux lots de graines créés

Figure 22: Rapport de soumission avec succès



• Les relations créées entre les lots de graines

• Les répétitions en cours

• Les lots de graines sans quantité initiale

• Les relations dans lesquelles la quantité utilisée n'est pas indiquée

• Les reproductions pour lesquelles les coordonnées ne sont pas indiquées

La page du rapport de soumission permet également de réaliser certaines actions qui sont détaillées
dans le chapitre suivant (Traitement post-soumission)

B.4.e.ii Interprétation des messages d'erreur

Dans certains cas la soumission d'un fichier peut soulever des erreurs (Figure 23) qui empêchent le
processus  de  soumission  d'aller  à  son  terme.  Dans  ce  cas,  toutes  les  opérations  en  cours  sont
annulées, et un rapport des erreurs trouvées est affiché.

Ces erreurs peuvent être de différentes natures :

• Une variable a été trouvée dans le fichier méthode ou le fichier de données et pas dans 
l'autre.

• Une ligne du fichier n'est associée à aucun projet

• Une méthode n'existe pas dans la base de données

• Une variété existe déjà dans la base de données (dans le cas de croisement ou de mélange)

• Utilisation d'un caractère interdit dans le nom d'une variété

Figure 23: Rapport d'erreurs



• Un acteur du réseau n'existe pas dans la base de données

• Le nom du lot de graines n'a pas été renseigné

• Le nom du lot de graines contient un caractère '#' inapproprié

• Le lot de graines n'existe pas dans la base de données

• Valeur invalide pour le champ 'split' (i.e. valeur différente de 0 ou 1)

• La nomenclature du lot de graines n'est pas respectée

• Des champs obligatoires sont vides

• Des groupes de corrélations incohérents

• Des incohérences sur les dates (semis après récolte par exemple)

• Erreurs sur la localisation des reproductions

B.4.f Traitement post-soumission

B.4.f.i Associer un type de variété

Dans le rapport de soumission il est possible d'associer les variétés nouvellement créées à un type
de variété. Pour cela, des types de variété doivent avoir été créés au préalable (Gestion des types de
variété).  Dans  le  tableau  présenté  Figure  24 la  colonne  'Choose  a  germplasm type'  permet  de
sélectionner quel type de variété sera associé à la variété citée dans la colonne 'Germplasm'. Une
fois que toutes les associations sont réalisées cliquer sur le bouton 'Submit'.

Il est possible de modifier par la suite le type de variété associé à une variété. Pour cela se référer au
chapitre Gestion des types de variété.

Figure 24: Formulaire permettant d'associer une variété à un type de variété



B.4.f.ii Associer une méthode de reproduction

Dans  le  rapport  de  soumission  il  est  possible  d'associer  une  méthode  de  reproduction  à  une
reproduction en cours. Pour cela des méthodes de reproduction doivent avoir été créés au préalable
(Gestion des méthodes de reproduction). Dans l'exemple présenté  Figure 25 la ligne 'Choose the
reproduction type' permet de sélectionner quel type de reproduction sera associé à la reproduction
décrite sur la ligne au dessus.  Une fois  que toutes les associations sont réalisées cliquer sur le
bouton 'Submit'.

Il est possible de modifier par la suite le type de reproduction associé à une reproduction.

B.4.f.iii Fusionner des répétitions après soumission

Dans le  rapport  de soumission  il  est  également  possible  de  fusionner  des  répétitions  en  cours.
Chaque série  de répétition  est  séparée  par  les  caractères  '***'  (Figure  26).  Des cases  à  cocher
permettent de sélectionner les lots de graines qui doivent être fusionnés. Une fois les lots de graines
sélectionnés,  cliquer  sur  le  bouton  'Merge'.  Il  faut  répéter  l'opération  pour  chaque  série  de
répétitions.

Une fusion de répétition créée un nouvel événement de mélange sans toutefois créer une nouvelle
variété (cas particulier du mélange). Attention, cette opération est irréversible.

Si l'utilisateur quitte la page de rapport sans avoir fusionné toutes ses répétitions, il est possible de

Figure 25: Formulaire permettant d'associer une méthode de reproduction à une reproduction en 
cours



réaliser cette opération par la suite (Créer des événements via l’interface).

B.4.g Éditer des données brutes

Depuis le menu Admin data > Seed lot relation > Any relation type > Edit raw data, un utilisateur
peut accéder à un formulaire simple de liste à complétion automatique dans lequel il peut choisir
une relation qui contient des données à éditer. Lorsque la fiche apparaît à l’écran l’utilisateur, s’il
est  administrateur  peut  cliquer  sur  une  valeur  et  afficher  un  formulaire  permettant  d’éditer  la

Figure 26: Fusion de répétitions après soumission

Figure 27: Formulaire d'edition des données brutes



donnée. Lors de l’édition l’utilisateur peut ajouter un commentaire afin d’expliquer les raisons de
cette édition ou simplement tracer l’ancienne valeur. La date de la dernière modification ainsi que le
nom de l’utilisateur sont tracés et affichés dans le tableau de données de la fiche au passage de la
souris sur la valeur elle même.

B.4.h Fusionner des répétitions

L’utilisateur  administrateur peut  regrouper des lots  de graines issus de répétitions bien après la
soumission d’un fichier de reproduction. Pour cela se rendre dans le menu Admin data > Tools >
Merge Reps. L’écran (Figure 28) liste l’ensemble des répétitions qu’il est possible de fusionner.
Pour chaque ligne, il est possible de sélectionner/dé-sélectionner les lots de graines à fusionner.

Sélectionner le projet auquel l’événement va être lié puis cliquer sur le bouton ‘Merge’. En cas de
succès un message apparaît avec le nom du lot de graines créé.

B.4.i Créer des événements via l’interface

Ces interfaces permettent de créer des événements ponctuels, indépendamment de la soumission par
fichier.  Elles  permettent  également  de  renseigner  des  événements  antérieurs  à  une  suite
d’événements déjà référencés dans la base de données. 

Figure 28: Ecran de fusion des répétitions



B.4.i.i Diffusion

Pour créer un événement de diffusion se rendre dans le menu Admin data > Network > Diffusion >
New.  L’interface  (Figure  29)  se  divise  en  trois  blocs  d’informations.  Dans  le  bloc  ‘Seed  lot
diffused’,  l’utilisateur  doit  renseigner  le  lot  de graines  diffusé  (à  choisir  dans  une  liste  de  lots
existants)  ou  bien  fournir  les  informations  pour  en  créer  un  nouveau.  Dans  le  bloc  ‘Diffusion
information’ l’utilisateur  renseigne le  lot  de graines  cible  de la  relation  de  diffusion soit  en le
sélectionnant  dans  une  liste,  soit  en  renseignant  les  informations  des  champs  ‘receiver’  et
‘event_year’ pour en créer un nouveau. L’utilisateur doit ensuite renseigner les autres champs du
bloc.  Les  différentes  règles  de création d’événements  de diffusion par  chargement  d’un fichier
(Traitements particuliers lors de la soumission d'un fichier) s’appliquent également à ce formulaire.
Il  est  à  noter  que  lorsque  l’utilisateur  sélectionne  un  lot  existant  dans  le  bloc  ‘Diffusion

information’,  celui  ci  ne  doit  pas  avoir  été  créé  par  une  autre  relation,  un  message  d’erreur
apparaîtra  dans le  cas  contraire.  Enfin dans  le  bloc ‘Additional  information’ un utilisateur  a la
possibilité d’ajouter des données liées à cet événement de diffusion. Un clic sur le bouton permet
d’afficher des lignes supplémentaires, cliquer ensuite sur le bouton ‘Create’ pour valider la création
de l’événement.

Figure 29: Formulaire de création d'une diffusion



B.4.i.ii Reproduction

Pour  créer  un  événement  de  reproduction  se  rendre  dans  le  menu  Admin  data  >  Network  >
Reproduction > New. L’interface (Figure 30) se divise en trois blocs d’informations. Dans le bloc
‘Sown seed lot information’, l’utilisateur doit renseigner le lot de graines semé (à choisir dans une
liste de lots existants) ou bien fournir les informations pour en créer un nouveau. Dans le bloc
‘Reproduction  information’ l’utilisateur  renseigne  le  lot  de  graines  récolté  de  la  relation  de

reproduction soit en le sélectionnant dans une liste, soit en renseignant les informations du champ
‘harvested_year’ pour en créer un nouveau. L’utilisateur doit ensuite renseigner les autres champs
du bloc.  Les  différentes  règles  de création  d’événements  de  reproduction  par  chargement  d’un
fichier  (Traitements  particuliers  lors  de la  soumission d'un fichier)  s’appliquent  également  à  ce
formulaire.  Il  est  à  noter  que  lorsque  l’utilisateur  sélectionne  un  lot  existant  dans  le  bloc
‘Reproduction information’, celui ci ne doit pas avoir été créé par une autre relation, un message
d’erreur apparaîtra dans le cas contraire. Enfin dans le bloc ‘Additional information’ un utilisateur a
la possibilité d’ajouter des données liées à cet événement de diffusion. Un clic sur le bouton (+)
permet d’afficher des lignes supplémentaires, cliquer ensuite sur le bouton ‘Create’ pour valider la
création de l’événement.

Figure 30: Formulaire de création d'une reproduction



B.4.i.iii  Sélection

Pour créer un événement de sélection se rendre dans le menu Admin data > Network > Selection >
New.  L’interface  (Figure  31)  se  divise  en  deux  blocs  d’informations.  Dans  le  bloc  ‘Selection
information’, l’utilisateur doit renseigner un événement de reproduction existant (à choisir dans une
liste ) puis renseigner les autres champs du bloc. Les différentes règles de création d’événements de
selection par chargement d’un fichier (Traitements particuliers lors de la soumission d'un fichier)
s’appliquent également à ce formulaire. Dans le bloc ‘Additional information’ un utilisateur a la

possibilité  d’ajouter  des  données liées  à cet  événement  de selection.  Un clic  sur  le  bouton (+)
permet d’afficher des lignes supplémentaires, cliquer ensuite sur le bouton ‘Create’ pour valider la
création de l’événement.

B.4.i.iv  Croisement

Pour créer un événement de croisement se rendre dans le menu Admin data > Network > Cross >
New. L’interface (Figure 32) se divise en quatre blocs d’informations. Dans le bloc ‘Male seed lot
information’, l’utilisateur doit renseigner le lot de graines mâle (à choisir dans une liste de lots
existants) ou bien fournir les informations pour en créer un nouveau (champs ‘location’, ‘year’, et
‘germplasm’), puis renseigner les informations relative au semis du lot mâle. Dans le bloc ‘Female
seed lot information’, l’utilisateur doit renseigner le lot de graines femelle (à choisir dans une liste
de lots existants) ou bien fournir les informations pour en créer un nouveau (champs ‘location’,
‘year’, et ‘germplasm’), puis renseigner les informations relative au semis du lot femelle. Dans le
bloc ‘Cross information’ l’utilisateur renseigne le lot de graines cible de la relation de croisement
soit en le sélectionnant dans une liste, soit en renseignant les informations des champs ‘species’ et
‘germplasm’ pour en créer un nouveau.

Figure 31: Formulaire de création d'une sélection



L’utilisateur doit ensuite renseigner les autres champs du bloc. Les différentes règles de création
d’événements  de  croisement  par  chargement  d’un  fichier  (Traitements  particuliers  lors  de  la

soumission  d'un  fichier)  s’appliquent  également  à  ce  formulaire.  Il  est  à  noter  que  lorsque
l’utilisateur sélectionne un lot existant dans le bloc ‘Cross information’, celui ci ne doit pas avoir
été créé par une autre relation, un message d’erreur apparaîtra dans le cas contraire. Enfin dans le
bloc  ‘Additional  information’ un  utilisateur  a  la  possibilité  d’ajouter  des  données  liées  à  cet
événement  de  croisement.  Un clic  sur  le  bouton permet  d’afficher  des  lignes  supplémentaires,
cliquer ensuite sur le bouton ‘Create’ pour valider la création de l’événement.

Figure 32: Formulaire de création d'un croisement



B.4.j Supprimer des informations

B.4.j.i Supprimer des événements via l’interface

Pour  supprimer  un  événement,  se  rendre  dans  le  menu   Admin  data  >  Network  >  « Type
d’événement » > Delete. L’utilisateur accède alors à une interface d’administration listant tous les
événements du type qu’il a choisi.  Sur la droite, des filtres permettent de restreindre cette liste.
Cette page permet de sélectionner plusieurs événements et de les supprimer par l’action ‘Delete
selected « event »’, toutefois cette méthode est à éviter car la suppression serait incomplète. Pour
supprimer  proprement  un  événement  cliquer  sur  son  nom.  La  page  de  détail  de  l’événement
s’affiche et propose deux possibilité de suppression.

• Le bouton ‘Delete’, permet de supprimer l’événement ainsi que toutes les données/mesures
qui s’y réfèrent à condition que la donnée en question ne soit pas liée à un autre événement.
Si le lot de graines « enfant » n’est utilisé dans aucune autre relation, celui ci est également
supprimé. 

• Le bouton ‘Delete in cascade’ permet de supprimer l’événement en question ainsi que tous
les événements postérieurs qui resultent de cet événement. De la même façon, toutes les
données/mesures qui s’y réfèrent sont supprimées à condition que la donnée en question ne
soit pas liée à un autre événement.

Dans les deux cas l’utilisateur est amené sur une page qui lui demande de confirmer la suppression.
Pour se faire cliquer sur le bouton ‘Yes I’m sure’. Dans le cas contraire cliquer sur ‘No, take me
back’

B.4.j.ii Supprimer des événements de reproduction depuis un fichier

Depuis le menu  Prepare & upload files > Delete  from file  > Reproduction un utilisateur  peut
supprimer un ensemble d’événements par soumission d’un fichier (Figure 33). La première étape
consiste  à  soumettre  le  fichier.  Ce  fichier  a  le  même format  que  celui  décrit  dans  le  chapitre
Préparer un fichier de reproductions existantes. La suppression peut être faite individuellement ou

en  cascade  comme  décrit  dans  le  paragraphe  Supprimer  des  événements  via  l’interface.  La
deuxième étape analyse le fichier et indique à l’utilisateur les événements qui vont être supprimé. Si

Figure 33: Suppression d'un événements de reproduction en 3 étapes



l’utilisateur valide, les événements sont définitivement supprimé et un rapport indique à l’utilisateur
l’ensemble des événements supprimés. L’utilisateur peut choisir d’annuler et revenir au formulaire
de soumission du fichier.

B.4.j.iii Supprimer des données depuis une requête

Depuis le menu Admin > Seed lot relation > Reproduction > Delete raw data un utilisateur peut
supprimer un jeu de données sans pour autant supprimer les reproductions associées à ces données.

Les données à supprimées peuvent être sélectionnées à l’aide d’un formulaire de requête (Figure 34)
permettant  de filtrer  suivant  le  germplasm, les variables,  une période,  l’année de semis  etc.  La
deuxième étape liste toutes les données brutes résultant de la requête en fonction des filtres choisis.
L’utilisateur  a  la  possibilité  de  cocher/décocher  chaque  donnée  avant  validation.  Dès  que
l’utilisateur  valide  sa  sélection,  un  rapport  de  suppression  est  affiché  indiquant  le  nombre  de
données supprimées pour chaque reproduction. A la suite de ce rapport l’utilisateur a la possibilité
de télécharger deux fichiers pré-remplis avec les relations et les variables pour lesquels des données
ont été supprimées.

C Consultation des données

C.1 formulaire de recherche globale

Depuis n’importe quel écran de SHiNeMaS, une barre de recherche globale est disponible en entête
de  l’interface  web  (Figure  35)  et  fournit  un  outil  utile  pour  rechercher  n’importe  quel  type
d’information (Germplasm, Lot de graines ou Relation) dans la base de données. La recherche est
réalisée par complétion automatique,  signifiant que l’utilisateur saisit  un début de texte dans la
barre, qui affiche ensuite une liste restreinte d’objets. Dès que le bouton « Aller » et cliqué la fiche
correspondante s’affiche dans l’interface web.

Figure 34: Étapes de suppression des données brutes à partir d'une requête



C.2 Requêtes avancées

C.2.a Les différents filtres

L'interface de requête avancée (Figure 36) permet de filtrer les résultats selon certains critères :

• 'Creation year' :  l'année de création du lot de graines. Il s'agit soit  de l'année de récolte,
d'arrivée à la ferme (dans le cas d'une diffusion), de création du mélange (dans le cas d'un
mélange), etc.

• 'Projects' : les projets dans lesquels le lot de graines a été utilisé

• 'Person' : La personne possédant ce lot de graines

• 'Relation  type' :  Filtre  sur  le  type  de  relation  qui  a  permis  d'obtenir  ce  lot  de  graines
(Diffusion, Mélange, Multiplication etc.)

• 'Germplasm' : Permet de filtrer sur une variété particulière

Figure 35: Barre de recherche globale



Chaque filtre propose une case 'Not' qui permet de définir un critère d'exclusion (« Tout sauf »...).
Cliquer ensuite sur le bouton « Search » pour appliquer le(s) filtre(s).

C.2.b Mode Classic

La requête en mode « Classic » affiche la liste des lots de graines (Figure 37) résultant du filtre
appliqué. Certaines informations supplémentaires sont disponibles :

• Seed lot name : Le nom du lot de graines

• Relation : Le type de relation dont résulte le lot de graines

• Parent names : Le nom des lots de graines parents

• Grandparents Relation : Le type de relation qui lie parents et grands-parents

• Grandparents : Le nom des lots de graines grands-parents

• Selection name : Nom de la sélection lorsque le lot de graines est issu d'une sélection

• Selection person : Personne qui a réalisé la sélection lorsque le lot de graines est issu d'une 
sélection

• Origin seed lot : Ferme d'origine du lot de graines

• Diffusion date : Année de dernière diffusion du lot de graines

Figure 36: Formulaire de reqête avancée



C.2.c Mode Generation

La  requête  en  mode  « Generation »  affiche  la  liste  des  lots  de  graines  filtrés  ainsi  que  les
informations sur le nombre de fois que ce lot de graines a été multiplié (sur la même ferme et au
total) (Figure 38):

• Seed lot name : Le nom du lot de graines

• First parents : Le nom des parents utilisés pour le croisement d'origine (lorsqu'il y a eu un
croisement)

• Total  number  of  generation : Le  nombre  total  de  multiplication  (génération)  avant
d'obtenir ce lot de graines

• Number of generation on the last farm : Le nombre de multiplication ayant eu lieu sur la
ferme avant d'obtenir ce lot de graines

• Confidence : La confiance accordée à l’information du nombre de génération. Par exemple

un  lot  de  graines  qui  intègre  spontanément  l’historique  du  réseau  aura  par  défaut  une
confiance à faux. 

Figure 37: Résultat d'une requête en mode "Classic"

Figure 38: Résultat d'une requête en mode "Generation"



• Confidence on last farm : La confiance accordée à l’information du nombre de génération
sur une même ferme.

C.2.d Mode Measures

La requête en mode «Measures» permet d'afficher les données mesurées sur une période donnée
(Figure  39).  L’utilisateur  renseigne  le  nom des  variables  à  afficher  ainsi  que  les  dates  pour  la
période voulue. Le résultats de la requête sera affiché dans trois sections distinctes :

• Les données liées aux lots de graines : le tableau affiche le nom des lots de graines ainsi
que les données mesurées qui leur sont directement liées.

• Les données individuelles liées à une relation : le tableau de résultat affiche le nom de la
relation ainsi que les coordonnées de la reproduction, le numéro de l’individu et les données
mesurées sur ces individus.

• Les données  globales  liées  à une relation :  le  tableau de résultat  affiche le  nom de la
relation  ainsi  que  les  coordonnées  de  la  reproduction,  et  les  données  mesurées  sur  ces
parcelles.

Figure 39: Résultat d'une requête en mode "Measures"



C.3 Table des sélections

La table des sélections (Figure 40) permet d'afficher un tableau contenant tous les noms de sélection

qui ont été utilisés pour une variété. Cette table se trouve dans le menu « Management > Selection
table ». Lorsque de nombreuses sélections ont déjà eues lieu un utilitaire permet de saisir un nom de
germplasm et un nom de sélection afin de tester si celui-ci a déjà été utilisé.

Figure 40: Table des sélections



C.4 Fiche lot de graines

Les requêtes avancées permettent d'afficher des listes de lots de graines (Requêtes avancées). En
cliquant sur le nom d'un lot de graines, il est possible d'accéder à la fiche d'un lot de graines (Figure
41).

Cette fiche informe l'utilisateur (cadre 'seed lot informations') sur la variété dont est issu le lot de
graines,  sont propriétaire,  sont année de création (récolte,  diffusion,  mélange etc.)  ainsi  que les
projets dans lesquels le lot de graines a été utilisé.

L'histoire du lot de graines est également affichée, notamment l’événement qui a créé ce lot de
graines, et le(s) événement(s) dans le(s)quel(s) il a été utilisé (cadre 'seed lot history').

Enfin,  le  cadre  'stock information',  affiche les  données  concernant  l’état  du stock de ce lot  de
graines.

Figure 41: Fiche lot de graines



C.5 Fiche variété

A partir d'une fiche lot de graines (chapitre Fiche lot de graines) il est possible de cliquer sur le nom
d'une variété pour afficher la fiche de celle-ci (Figure 42).

Le cadre 'Germplasm informations' indique le nom de la variété, la personne qui a créé cette variété
lorsque l'information est disponible, ainsi que le type de variété dont il s'agit.

Le cadre 'Germplasm history' indique comment cette variété a été créée, notamment lorsqu'il s'agit
d'un croisement ou d'un mélange.

Enfin,  le  cadre 'stock information'  indique qui dans le  réseau possède des lots  de graines cette
variété. Des information de contact apparaissent lorsqu'elles sont disponibles.

C.6 Fiche Relation

A partir d’une fiche de lots de graines (chapitre Fiche lot de graines) il est possible de cliquer sur
l’icône ‘relation’ pour afficher la fiche (Figure 43) de celle-ci. 

Figure 42: Fiche variété





Le  cadre  ‘Relation  information’ indique  le  type  de  relation  ainsi  que  toutes  les  informations
relatives à cette relation (dates, coordonnées lorsqu’il s’agit d’un croisement ou une reproduction,
les quantités utilisées etc.).

Le cadre ‘Data’ répertorie toutes les données qui sont liées à cette relation.

C.7 Télécharger des données

Depuis n’importe quelle fiche ou depuis les tableaux de résultats de requête avancée, il est possible 
de télécharger les données en cliquant sur l’icône  .

D Lexique
• Répétitions : parcelles d’essai qui contient le même lot de semence.

• Reproduction : la reproduction correspond au cycle de la plante, une graine va pousser pour
donner d’autres graines.

• Sélection : au sein d’un lot de semences, sélection de certains individus pour constituer un
nouveau lot de semence. C’est une sélection intra-variétale.

Figure 43: Fiche relation



• Variété  :   Ensemble  de  plantes  présentant  des  caractéristiques  phénotypiques  les
rapprochant.
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and legibly identify you as the publisher of these copies. The front cover must present the full title 
with all words of the title equally prominent and visible. You may add other material on the covers 



in addition. Copying with changes limited to the covers, as long as they preserve the title of the 
Document and satisfy these conditions, can be treated as verbatim copying in other respects.
If the required texts for either cover are too voluminous to fit legibly, you should put the first ones 
listed (as many as fit reasonably) on the actual cover, and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must 
either include a machine-readable Transparent copy along with each Opaque copy, or state in or 
with each Opaque copy a computer-network location from which the general network-using public 
has access to download using public-standard network protocols a complete Transparent copy of the
Document, free of added material. If you use the latter option, you must take reasonably prudent 
steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent 
copy will remain thus accessible at the stated location until at least one year after the last time you 
distribute an Opaque copy (directly or through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before 
redistributing any large number of copies, to give them a chance to provide you with an updated 
version of the Document.

4. MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the conditions of sections 2
and 3 above, provided that you release the Modified Version under precisely this License, with the 
Modified Version filling the role of the Document, thus licensing distribution and modification of 
the Modified Version to whoever possesses a copy of it. In addition, you must do these things in the 
Modified Version:

• A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document,
and from those of previous versions (which should, if there were any, be listed in the History
section of the Document). You may use the same title as a previous version if the original 
publisher of that version gives permission.

• B. List on the Title Page, as authors, one or more persons or entities responsible for 
authorship of the modifications in the Modified Version, together with at least five of the 
principal authors of the Document (all of its principal authors, if it has fewer than five), 
unless they release you from this requirement.

• C. State on the Title page the name of the publisher of the Modified Version, as the 
publisher.

• D. Preserve all the copyright notices of the Document.
• E. Add an appropriate copyright notice for your modifications adjacent to the other 

copyright notices.
• F. Include, immediately after the copyright notices, a license notice giving the public 

permission to use the Modified Version under the terms of this License, in the form shown 
in the Addendum below.

• G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts
given in the Document's license notice.

• H. Include an unaltered copy of this License.
• I. Preserve the section Entitled "History", Preserve its Title, and add to it an item stating at 

least the title, year, new authors, and publisher of the Modified Version as given on the Title 
Page. If there is no section Entitled "History" in the Document, create one stating the title, 
year, authors, and publisher of the Document as given on its Title Page, then add an item 
describing the Modified Version as stated in the previous sentence.

• J. Preserve the network location, if any, given in the Document for public access to a 
Transparent copy of the Document, and likewise the network locations given in the 
Document for previous versions it was based on. These may be placed in the "History" 
section. You may omit a network location for a work that was published at least four years 



before the Document itself, or if the original publisher of the version it refers to gives 
permission.

• K. For any section Entitled "Acknowledgements" or "Dedications", Preserve the Title of the 
section, and preserve in the section all the substance and tone of each of the contributor 
acknowledgements and/or dedications given therein.

• L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their 
titles. Section numbers or the equivalent are not considered part of the section titles.

• M. Delete any section Entitled "Endorsements". Such a section may not be included in the 
Modified Version.

• N. Do not retitle any existing section to be Entitled "Endorsements" or to conflict in title 
with any Invariant Section.

• O. Preserve any Warranty Disclaimers.
If the Modified Version includes new front-matter sections or appendices that qualify as Secondary 
Sections and contain no material copied from the Document, you may at your option designate 
some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections 
in the Modified Version's license notice. These titles must be distinct from any other section titles.
You may add a section Entitled "Endorsements", provided it contains nothing but endorsements of 
your Modified Version by various parties—for example, statements of peer review or that the text 
has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words 
as a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only one 
passage of Front-Cover Text and one of Back-Cover Text may be added by (or through 
arrangements made by) any one entity. If the Document already includes a cover text for the same 
cover, previously added by you or by arrangement made by the same entity you are acting on behalf
of, you may not add another; but you may replace the old one, on explicit permission from the 
previous publisher that added the old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use their 
names for publicity for or to assert or imply endorsement of any Modified Version.

5. COMBINING DOCUMENTS

You may combine the Document with other documents released under this License, under the terms
defined in section 4 above for modified versions, provided that you include in the combination all 
of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant 
Sections of your combined work in its license notice, and that you preserve all their Warranty 
Disclaimers.
The combined work need only contain one copy of this License, and multiple identical Invariant 
Sections may be replaced with a single copy. If there are multiple Invariant Sections with the same 
name but different contents, make the title of each such section unique by adding at the end of it, in 
parentheses, the name of the original author or publisher of that section if known, or else a unique 
number. Make the same adjustment to the section titles in the list of Invariant Sections in the license
notice of the combined work.

In the combination, you must combine any sections Entitled "History" in the various original 
documents, forming one section Entitled "History"; likewise combine any sections Entitled 
"Acknowledgements", and any sections Entitled "Dedications". You must delete all sections 
Entitled "Endorsements".

6. COLLECTIONS OF DOCUMENTS

You may make a collection consisting of the Document and other documents released under this 
License, and replace the individual copies of this License in the various documents with a single 
copy that is included in the collection, provided that you follow the rules of this License for 



verbatim copying of each of the documents in all other respects.
You may extract a single document from such a collection, and distribute it individually under this 
License, provided you insert a copy of this License into the extracted document, and follow this 
License in all other respects regarding verbatim copying of that document.

7. AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and independent documents or
works, in or on a volume of a storage or distribution medium, is called an "aggregate" if the 
copyright resulting from the compilation is not used to limit the legal rights of the compilation's 
users beyond what the individual works permit. When the Document is included in an aggregate, 
this License does not apply to the other works in the aggregate which are not themselves derivative 
works of the Document.
If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the 
Document is less than one half of the entire aggregate, the Document's Cover Texts may be placed 
on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if 
the Document is in electronic form. Otherwise they must appear on printed covers that bracket the 
whole aggregate.

8. TRANSLATION

Translation is considered a kind of modification, so you may distribute translations of the Document
under the terms of section 4. Replacing Invariant Sections with translations requires special 
permission from their copyright holders, but you may include translations of some or all Invariant 
Sections in addition to the original versions of these Invariant Sections. You may include a 
translation of this License, and all the license notices in the Document, and any Warranty 
Disclaimers, provided that you also include the original English version of this License and the 
original versions of those notices and disclaimers. In case of a disagreement between the translation 
and the original version of this License or a notice or disclaimer, the original version will prevail.
If a section in the Document is Entitled "Acknowledgements", "Dedications", or "History", the 
requirement (section 4) to Preserve its Title (section 1) will typically require changing the actual 
title.

9. TERMINATION

You may not copy, modify, sublicense, or distribute the Document except as expressly provided 
under this License. Any attempt otherwise to copy, modify, sublicense, or distribute it is void, and 
will automatically terminate your rights under this License.
However, if you cease all violation of this License, then your license from a particular copyright 
holder is reinstated (a) provisionally, unless and until the copyright holder explicitly and finally 
terminates your license, and (b) permanently, if the copyright holder fails to notify you of the 
violation by some reasonable means prior to 60 days after the cessation.

Moreover, your license from a particular copyright holder is reinstated permanently if the copyright 
holder notifies you of the violation by some reasonable means, this is the first time you have 
received notice of violation of this License (for any work) from that copyright holder, and you cure 
the violation prior to 30 days after your receipt of the notice.

Termination of your rights under this section does not terminate the licenses of parties who have 
received copies or rights from you under this License. If your rights have been terminated and not 
permanently reinstated, receipt of a copy of some or all of the same material does not give you any 
rights to use it.

10. FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU Free Documentation 



License from time to time. Such new versions will be similar in spirit to the present version, but 
may differ in detail to address new problems or concerns. See https://www.gnu.org/licenses/.
Each version of the License is given a distinguishing version number. If the Document specifies that
a particular numbered version of this License "or any later version" applies to it, you have the 
option of following the terms and conditions either of that specified version or of any later version 
that has been published (not as a draft) by the Free Software Foundation. If the Document does not 
specify a version number of this License, you may choose any version ever published (not as a 
draft) by the Free Software Foundation. If the Document specifies that a proxy can decide which 
future versions of this License can be used, that proxy's public statement of acceptance of a version 
permanently authorizes you to choose that version for the Document.

11. RELICENSING

"Massive Multiauthor Collaboration Site" (or "MMC Site") means any World Wide Web server that 
publishes copyrightable works and also provides prominent facilities for anybody to edit those 
works. A public wiki that anybody can edit is an example of such a server. A "Massive Multiauthor 
Collaboration" (or "MMC") contained in the site means any set of copyrightable works thus 
published on the MMC site.
"CC-BY-SA" means the Creative Commons Attribution-Share Alike 3.0 license published by 
Creative Commons Corporation, a not-for-profit corporation with a principal place of business in 
San Francisco, California, as well as future copyleft versions of that license published by that same 
organization.

"Incorporate" means to publish or republish a Document, in whole or in part, as part of another 
Document.

An MMC is "eligible for relicensing" if it is licensed under this License, and if all works that were 
first published under this License somewhere other than this MMC, and subsequently incorporated 
in whole or in part into the MMC, (1) had no cover texts or invariant sections, and (2) were thus 
incorporated prior to November 1, 2008.

The operator of an MMC Site may republish an MMC contained in the site under CC-BY-SA on the
same site at any time before August 1, 2009, provided the MMC is eligible for relicensing.

https://www.gnu.org/licenses/
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